Crashing Robots POJ2632

Crashing Robots
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4556 Accepted: 1991

Description

In a modernized warehouse, robots are used to fetch the goods. Careful planning is needed to ensure that the robots reach their destinations without crashing into each other. Of course, all warehouses are rectangular, and all robots occupy a circular floor space with a diameter of 1 meter. Assume there are N robots, numbered from 1 through N. You will get to know the position and orientation of each robot, and all the instructions, which are carefully (and mindlessly) followed by the robots. Instructions are processed in the order they come. No two robots move simultaneously; a robot always completes its move before the next one starts moving. 
A robot crashes with a wall if it attempts to move outside the area of the warehouse, and two robots crash with each other if they ever try to occupy the same spot.

Input

The first line of input is K, the number of test cases. Each test case starts with one line consisting of two integers, 1 <= A, B <= 100, giving the size of the warehouse in meters. A is the length in the EW-direction, and B in the NS-direction. 
The second line contains two integers, 1 <= N, M <= 100, denoting the numbers of robots and instructions respectively. 
Then follow N lines with two integers, 1 <= Xi <= A, 1 <= Yi <= B and one letter (N, S, E or W), giving the starting position and direction of each robot, in order from 1 through N. No two robots start at the same position. 
 
Figure 1: The starting positions of the robots in the sample warehouse

Finally there are M lines, giving the instructions in sequential order. 
An instruction has the following format: 
< robot #> < action> < repeat> 
Where is one of 
  • L: turn left 90 degrees, 
  • R: turn right 90 degrees, or 
  • F: move forward one meter,

and 1 <= < repeat> <= 100 is the number of times the robot should perform this single move.

Output

Output one line for each test case: 
  • Robot i crashes into the wall, if robot i crashes into a wall. (A robot crashes into a wall if Xi = 0, Xi = A + 1, Yi = 0 or Yi = B + 1.) 
  • Robot i crashes into robot j, if robots i and j crash, and i is the moving robot. 
  • OK, if no crashing occurs.

Only the first crash is to be reported.

Sample Input

4
5 4
2 2
1 1 E
5 4 W
1 F 7
2 F 7
5 4
2 4
1 1 E
5 4 W
1 F 3
2 F 1
1 L 1
1 F 3
5 4
2 2
1 1 E
5 4 W
1 L 96
1 F 2
5 4
2 3
1 1 E
5 4 W
1 F 4
1 L 1
1 F 20

Sample Output

Robot 1 crashes into the wall
Robot 1 crashes into robot 2
OK
Robot 1 crashes into robot 2


模拟算法:根据题目所述移动步骤逐步进行,利用数组array[i][j]代表(i,j)位置处的robot编号,没有则为0.

利用robot结构体记录下每个机器人当前的位置和方向。

对于'F'指令,需判断前进是否出界和前进的位置是否已有机器人。

对于'L'和'R'转向指令,只需修改机器人的方向值,注意同一方向转四次等于没转。

代码如下:

#include <iostream>
using namespace std;
	
int array[101][101];
int a,b;
int xf[4]={-1,0,1,0};
int yf[4]={0,1,0,-1};
struct Robot
{
	int x;
	int y;
	int d;
}robot[101];

bool forward(int s,int t)
{
	int x,y;
	int d = robot[s].d;
	x=robot[s].x;
	y=robot[s].y;
	array[x][y]=0;
	for(int i=0;i<t;i++)
	{
		x =  x + xf[d];
		y =  y + yf[d];
		if(x<1 || x>a || y<1 || y>b)
		{cout<<"Robot "<<s<<" crashes into the wall"<<endl;return true;}
		if(array[x][y])
		{cout<<"Robot "<<s<<" crashes into robot "<<array[x][y]<<endl;return true;}
	}
	robot[s].x=x;
	robot[s].y=y;
	array[x][y]=s;
	return false;
}

bool action(int s,char dir,int t)
{
	switch (dir)
	{
		case 'F':return forward(s,t);
		case 'L':robot[s].d=(robot[s].d-t%4+4)%4;break;
		case 'R':robot[s].d=(robot[s].d+t%4)%4;break;
	}
	return false;
}

int main()
{
	freopen("in.txt","r",stdin);
	int k,n,m,xi,yi,i,j,s,t;
	cin>>k;

	char dir;
	bool f=false;
	for(i=0;i<k;i++)
	{
		memset(array,0,sizeof(int)*101*101);
		memset(robot,0,sizeof(Robot)*101);
		cin>>a>>b>>n>>m;
		for(j=0;j<n;j++)
		{
			cin>>xi>>yi>>dir;
			array[xi][yi]=j+1;
			robot[j+1].x=xi;
			robot[j+1].y=yi;
			switch(dir)
			{
				case 'W':robot[j+1].d=0;break;
				case 'N':robot[j+1].d=1;break;
				case 'E':robot[j+1].d=2;break;
				case 'S':robot[j+1].d=3;break;
				default:robot[j+1].d=-1;
			}
		}
		f=false;
		for(j=0;j<m;j++)
		{
			cin>>s>>dir>>t;
			if(!f)f=action(s,dir,t);
		}
		if(!f)cout<<"OK"<<endl;
	}

	return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值