Java 算法 德才论

题目描述

宋代史学家司马光在《资治通鉴》中有一段著名的“德才论”:“是故才德全尽谓之圣人,才德兼亡谓之愚人,德胜才谓之君子,才胜德谓之小人。凡取人之术,苟不得圣人,君子而与之,与其得小人,不若得愚人。”

现给出一批考生的德才分数,请根据司马光的理论给出录取排名。

输入
输入第一行给出 3 个正整数,分别为:N(≤105),即考生总数;L(≥60),为录取最低分数线,即德分和才分均不低于L的考生才有资格被考虑录取;H(<100),为优先录取线——德分和才分均不低于此线的被定义为“才德全尽”,此类考生按德才总分从高到低排序;才分不到但德分到线的一类考生属于“德胜才”,也按总分排序,但排在第一类考生之后;德才分均低于H,但是德分不低于才分的考生属于“才德兼亡”但尚有“德胜才”者,按总分排序,但排在第二类考生之后;其他达到最低线L的考生也按总分排序,但排在第三类考生之后。

随后N行,每行给出一位考生的信息,包括:准考证号 德分 才分,其中准考证号为 8 位整数,德才分为区间 [0, 100] 内的整数。数字间以空格分隔

输出
输出第一行首先给出达到最低分数线的考生人数M,随后M行,每行按照输入格式输出一位考生的信息,考生按输入中说明的规则从高到低排序。当某类考生中有多人总分相同时,按其德分降序排列;若德分也并列,则按准考证号的升序输出。

输入样例 1

14 60 80
10000001 64 90
10000002 90 60
10000011 85 80
10000003 85 80
10000004 80 85
10000005 82 77
10000006 83 76
10000007 90 78
10000008 75 79
10000009 59 90
10000010 88 45
10000012 80 100
10000013 90 99
10000014 66 60
输出样例 1

12
10000013 90 99
10000012 80 100
10000003 85 80
10000011 85 80
10000004 80 85
10000007 90 78
10000006 83 76
10000005 82 77
10000002 90 60
10000014 66 60
10000008 75 79
10000001 64 90
输入样例 2

5 60 80
100000000 60 70
100000001 80 80
100000002 50 50
100000003 50 90
100000004 60 60
输出样例 2

3
100000000 60 70
100000001 80 80
100000004 60 60
输入样例 3

4 80 80
10000000 80 90
10000001 70 30
10000002 80 70
10000003 100 100
输出样例 3

2
10000000 80 90
10000003 100 100

解题思路

由题可知分为四个等级(都按照总分排):
1.德分和才分都大于H
2.德分大于L,才分小于H
3.德分,才分都小于H 且德分大于才分
4.德分才分都大于L 且 德分小于才分
之后就是输入的事情了,可以建一个字符串数组,然后分成3份,分别存储准考证号 德分 才分。之后再依次分类后排序输出就行了。

代码

import java.util.*;
import java.util.stream.Collectors;

public class Main {
    //定义一个类存储考生考号分数等信息
    public static class Person implements Comparable<Person>{
        //准考证号
        private final int number;
        //德分
        private final int dScore;
        //才分
        private final int cScore;
        //总分
        private final int total;

        private Person(int number, int dScore, int cScore){
            this.number = number;
            this.dScore = dScore;
            this.cScore = cScore;
            //总分为 德分+才分
            total = dScore + cScore;
        }
        @Override
        public int compareTo(Person o) {
            if(o.total - this.total != 0){
                return o.total - this.total;
            }else if(o.dScore - this.dScore != 0){
                return o.dScore - this.dScore;
            }else{
                return this.cScore - o.cScore;
            }
        }
    }

    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        //考生数量
        int n = sc.nextInt();
        //录取最低分数线
        int l = sc.nextInt();
        //优先录取线
        int h = sc.nextInt();
        //存储输入的考生对象信息
        List<Person> list = new ArrayList<>();
        //读取考生信息
        while(n-- != 0){
            //赋值
            list.add(new Person(sc.nextInt(),sc.nextInt(),sc.nextInt()));
        }
        sc.close();
        //先过滤掉dScore或者cScore在录取最低分数线下的考生
        list = list.stream().filter(v->v.cScore >= l && v.dScore >= l).collect(Collectors.toList());
        //按规则排序  第一类 dScore和cScore均高于h  按照总分降序
        List<Person> one = new ArrayList<>();
        List<Person> two = new ArrayList<>();
        List<Person> three = new ArrayList<>();
        //dScore和cScore均高于l 低于h
        List<Person> four = new ArrayList<>();
        //筛出不同类别按照给定规则排序
        for(Person p : list){
            //才德全尽
            if(p.dScore >= h && p.cScore >= h){
                one.add(p);
            }else if(p.dScore >= h &&  p.cScore < h){
                //德胜才
                two.add(p);
            }else if(p.dScore <= h && p.cScore <=h && p.dScore >= p.cScore){
                //“才德兼亡”但尚有“德胜才”者
                three.add(p);
            }else{
                four.add(p);
            }
        }
        //排序
        Collections.sort(one);
        Collections.sort(two);
        Collections.sort(three);
        Collections.sort(four);
        //总计
        System.out.println(one.size()+two.size()+three.size()+four.size());
        //按照格式输出
        for (Person person : one) {
            System.out.println(person.number + " " + person.dScore + " " + person.cScore);
        }
        for (Person person : two) {
            System.out.println(person.number + " " + person.dScore + " " + person.cScore);
        }
        for (Person person : three) {
            System.out.println(person.number + " " + person.dScore + " " + person.cScore);
        }
        for (Person person : four) {
            System.out.println(person.number + " " + person.dScore + " " + person.cScore);
        }
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
根据给出的输入样例,我们可以看到有14位考生的信息。每位考生的信息包括准考证号、德分和才分。其中,考生的准考证号是8位整数,德分和才分都是在区间[0, 100]内的整数。接下来是要输出的内容。第一行输出的是达到最低分数线的考生人数M,接下来的M行按要求输出考生的信息。考生按照总分从高到低排序,如果总分相同,则按照德分降序排列,如果德分也相同,则按照准考证号升序输出。 根据这个规则,我们可以找到准考证号为1015的考生在测试点2的输出结果。在输出样例中,M的值为12,表示符合要求的考生人数为12人。接下来的M行按要求输出了考生的信息,其中包括准考证号、德分和才分。 所以,要找到1015德才论测试点2的结果,我们需要找到输出样例中的准考证号为1015的考生信息。最后的输出结果为:10000013 90 99 。 因此,准考证号为1015的考生在德才论测试点2的输出结果是10000013,德分为90,才分为99。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* *2* *3* [1015 德才论 (25 分)+测试点](https://blog.csdn.net/xyqqwer/article/details/89313345)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_2"}}] [.reference_item style="max-width: 100%"] [ .reference_list ]

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

future furuer

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值