LayneYao的博客

天道酬勤,运筹帷幄

Android Studio从2.3升级到3.0之后apt报错

今天早上一上班打开Android Studio就把它更新到3.0,但是各种更新之后发现项目不能运行了,查看了一下,打印的错误是:

Error:A problem occurred configuring project ':app'.
> android-apt plugin is incompatible with the Android Gradle plugin.  Please use 'annotationProcessor' configuration instead.

错误截图:



问题就出在butterknife,解决办法:

1、在project中的app文件的build.gradle文件里删除

apply plugin: 'com.neenbedankt.android-apt'

2、接着把buildscript的dependencies中删掉

classpath 'com.neenbedankt.gradle.plugins:android-apt:1.8'

3、最后把dependencies中的替换掉

//    apt 'com.jakewharton:butterknife-compiler:8.0.1'
    annotationProcessor 'com.jakewharton:butterknife-compiler:8.0.1'


阅读更多

扫码向博主提问

去开通我的Chat快问

jsagacity

一个技术人
  • 擅长领域:
  • Android开发
  • 偏物联网方向
版权声明:著作权归作者所有。商业转载请联系作者获得授权,非商业转载请注明作者和出处。 https://blog.csdn.net/Jsagacity/article/details/78349949
文章标签: android studio apt错误
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭