poj-1002

http://poj.org/problem?id=1002

487-3279
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 204325 Accepted: 35622

Description

Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP. Sometimes only part of the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino's by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could order your pizza from Pizza Hut by calling their ``three tens'' number 3-10-10-10. 

The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows: 

A, B, and C map to 2 
D, E, and F map to 3 
G, H, and I map to 4 
J, K, and L map to 5 
M, N, and O map to 6 
P, R, and S map to 7 
T, U, and V map to 8 
W, X, and Y map to 9 

There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010. 

Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.) 

Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number. 

Input

The input will consist of one case. The first line of the input specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers in the directory, with each number alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters. 

Output

Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number appears in the directory. Arrange the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line: 

No duplicates. 

Sample Input

12
4873279
ITS-EASY
888-4567
3-10-10-10
888-GLOP
TUT-GLOP
967-11-11
310-GINO
F101010
888-1200
-4-8-7-3-2-7-9-
487-3279

Sample Output

310-1010 2
487-3279 4
888-4567 3

Source


#include<stdio.h>
#include<string.h>

#define N 10000000

int id[10000000]={0};             //需要注意的是:数组一定要不能放在main函数内。之前我没意识到这个问题,提交一直是runtime error。 后来,想了一下,明白为什么了,在函数内,数组从栈中分配,没那么大空间,所以一直会错误。设为全局数组就OK了。

char map(char c)
{
	if(c=='0'||c=='1')
		return c;
	if(c=='2'||c=='A'||c=='B'||c=='C')
		return '2';
	if(c=='3'||c=='D'||c=='E'||c=='F')
		return '3';
	if(c=='4'||c=='G'||c=='H'||c=='I')
		return '4';
	if(c=='5'||c=='J'||c=='K'||c=='L')
		return '5';
	if(c=='6'||c=='M'||c=='N'||c=='O')
		return '6';
	if(c=='7'||c=='P'||c=='R'||c=='S')
		return '7';
	if(c=='8'||c=='T'||c=='U'||c=='V')
		return '8';
	if(c=='9'||c=='W'||c=='X'||c=='Y')
		return '9';
}

int main()
{
	int count;
	int flag=1;
	int i,k,t,len;
	char v,str[100];
	for(i=0;i<N;i++)
		id[i]=0;
	scanf("%d",&k);
	while(k--)
	{
		scanf("%s",str);
		t=0;
		len=strlen(str);
		for(i=0;i<len;i++)
		{
			if(str[i]=='-')
				continue;
			v=map(str[i]);
			t=t*10+(v-'0');			
		}
		id[t]++;
	}
	for(i=0;i<N;i++)
		if(id[i]>1)
		{
			printf("%03d-%04d %d\n",i/10000,i%10000,id[i]);
			flag=0;
		}
	if(flag)
		printf("No duplicates.\n");
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值