基于C#解决OJ刷题之输入输出问题的总结(AKOJ1064-1071A+B问题汇总)

     声明:题目部分为akoj题目,代码为本人AC代码。

     由于本人学校的oj支持各种环境,很正常的其中就包含了C#,然暑假在家较为空闲,本着学习C#和复习算法的态度和目的,就又开始折腾起oj了。

     题目部分是最基础的A+B系列,来看看C#的输入输出是怎么一回事吧

     题目地址:http://183.167.205.82:8081/JudgeOnline/problemlist?volume=1

     本文由csdn-jtahstu原创,转载请注明出处,欢迎志同道合的朋友一起交流学习。本人QQ:1373758426 和 博客链接:blog.csdn.net/jtahstu

ok

A+B(1)

Time Limit:1000MS  Memory Limit:65536K
Total Submit:629 Accepted:352

Description

Your task is to Calculate a + b.
Too easy?! Of course! I specially designed the problem for acm beginners.
You must have found that some problems have the same titles with this one, yes, all these problems were designed for the same aim.

Input

The input will consist of a series of pairs of integers a and b, separated by a space, one pair of integers per line.

Output

For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.

Sample Input

1 5
10 20

Sample Output

6
30
Source

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;

namespace AK1064
{
    class Program
    {
        static void Main(string[] args)
        {
            string sb;
            while ((sb = Console.ReadLine()) != null)
            {
                string[] s = sb.Split();
                int x = int.Parse(s[0]), y = int.Parse(s[1]);
                Console.WriteLine(x + y);
            }
        }
    }
}
C#的输入系统很恶心,只能一行一行读,然后分离出里面的数据,再转换成你想要的类型,然后才能处理

A+B(2)

Time Limit:1000MS  Memory Limit:65536K

  • 3
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值