HDU 3001 Travelling

132 篇文章 0 订阅
15 篇文章 0 订阅

Problem Description

After coding so many days,Mr Acmer wants to have a good rest.So travelling is the best choice!He has decided to visit n cities(he insists on seeing all the cities!And he does not mind which city being his start station because superman can bring him to any city at first but only once.), and of course there are m roads here,following a fee as usual.But Mr Acmer gets bored so easily that he doesn't want to visit a city more than twice!And he is so mean that he wants to minimize the total fee!He is lazy you see.So he turns to you for help.

Input

There are several test cases,the first line is two intergers n(1<=n<=10) and m,which means he needs to visit n cities and there are m roads he can choose,then m lines follow,each line will include three intergers a,b and c(1<=a,b<=n),means there is a road between a and b and the cost is of course c.Input to the End Of File.

Output

Output the minimum fee that he should pay,or -1 if he can't find such a route.

Sample Input

2 1
1 2 100
3 2
1 2 40
2 3 50
3 3
1 2 3
1 3 4
2 3 10

Sample Output

100
90

7

每个城市可以走两次,只能弄成三进制的状态压缩,然后dp了。

#include<stdio.h>
#include<string.h>
#define max 60000
int a[] = { 0, 1, 3, 9, 27, 81, 243, 729, 2187, 6561, 19683, max };
int b[max][11], f[max][11], d[11][11];

int main(){
	int min, i, j, k, n, m;
	for (i = 0; i <= max; i++)
	{
		k = i;
		for (b[i][0] = 0, j = 1; j <= 10; j++)
		{
			b[i][j] = k % 3;
			b[i][0] += b[i][j] && 1;
			k = k / 3;
		}
	}
	while (scanf("%d%d", &n, &m) != EOF)
	{
		min = 999999999;
		memset(f, 0, sizeof(f));
		memset(d, 0, sizeof(d));
		for (i = 1; i <= m; i++)
		{
			int a, b, c; scanf("%d%d%d", &a, &b, &c);
			if (d[a][b] == 0 || d[a][b]>c)	d[a][b] = d[b][a] = c;
		}
		for (i = 0; i <= a[n + 1]; i++)
		{
			for (j = 1; j <= n; j++)
				if (f[i][j]||b[i][0]==1&&b[i][j]==1)
					for (k = 1; k <= n; k++)
						if (d[k][j] && i + a[k] <= a[n + 1] && b[i][k]<2)
								if (f[i + a[k]][k] == 0 || f[i + a[k]][k]>f[i][j] + d[j][k])
										f[i + a[k]][k] = f[i][j] + d[j][k];
			if (b[i][0] == n)
				for (j = 1; j <= n; j++)
					if (f[i][j]) min = min<f[i][j] ? min : f[i][j];
		}
		if (min != 999999999)  printf("%d\n", min); else printf("-1\n");
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值