HDU 5272 Dylans loves numbers

Problem Description
Who is Dylans?You can find his ID in UOJ and Codeforces.
His another ID is s1451900 in BestCoder.

And now today's problems are all about him.

Dylans is given a number  N .
He wants to find out how many groups of "1" in its Binary representation.

If there are some "0"(at least one)that are between two "1",
then we call these two "1" are not in a group,otherwise they are in a group.
 

Input
In the first line there is a number  T .

T  is the test number.

In the next  T  lines there is a number  N .

0N1018,T1000
 

Output
For each test case,output an answer.
 

Sample Input
  
  
1 5
 

Sample Output
  
  
2

简单题

#include<iostream>
#include<cstdio>
#include<vector>
#include<iostream>
#include<queue>
#include<cstdlib>
using namespace std;
const int maxn = 100005;
int T, sum, f;
__int64 n;

int main()
{
    scanf("%d", &T);
    while (T--)
    {
        scanf("%I64d", &n);
        for (sum = 0, f = 0; n; n >>= 1)
        {
            if ((n & 1) && f == 0) sum++;
            f = n & 1;
        }
        printf("%d\n", sum);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值