HDU 5272 Dylans loves numbers

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5272


题面:

Dylans loves numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 241    Accepted Submission(s): 160


Problem Description
Who is Dylans?You can find his ID in UOJ and Codeforces.
His another ID is s1451900 in BestCoder.

And now today's problems are all about him.

Dylans is given a number  N .
He wants to find out how many groups of "1" in its Binary representation.

If there are some "0"(at least one)that are between two "1",
then we call these two "1" are not in a group,otherwise they are in a group.
 

Input
In the first line there is a number  T .

T  is the test number.

In the next  T  lines there is a number  N .

0N1018,T1000
 

Output
For each test case,output an answer.
 

Sample Input
  
  
1 5
 

Sample Output
  
  
2
 

Source
 


解题:

就是求将一个数转成二进制后,其中有几块“1”。因为首位肯定为1,所以只要往后多加一个“0”。然后数连续“10”的个数即可。


代码:

#include <iostream>
#include <string>
#include <algorithm>
using namespace std;
int main()
{
	int t,x,cnt;
	unsigned long long n;
	string s;
	cin>>t;
	while(t--)
	{
		cin>>n;
		cnt=0;
		s="";
		while(n)
		{
		  x=n&1;
		  if(x)	s+='1';
		  else s+='0';
		  n>>=1;
		}
		reverse(s.begin(),s.end());
		s+='0';
		int len=s.length()-1;
		for(int i=0;i<len;i++)
		{
			if(s[i]=='1'&&s[i+1]=='0')
			cnt++;
		}
		cout<<cnt<<endl;
	}
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值