HDU 4565 So Easy!

Problem Description

  A sequence S n is defined as:

Where a, b, n, m are positive integers.┌x┐is the ceil of x. For example, ┌3.14┐=4. You are to calculate S n.
  You, a top coder, say: So easy! 

Input

  There are several test cases, each test case in one line contains four positive integers: a, b, n, m. Where 0< a, m < 2 15, (a-1) 2< b < a 2, 0 < b, n < 2 31.The input will finish with the end of file.

Output

  For each the case, output an integer S n.

Sample Input

2 3 1 2013
2 3 2 2013
2 2 1 2013

Sample Output

4
14

4

关键是找到递推式

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
typedef long long use;
use n,m,a,b,x[2][3],y[2][3],c[3][3],e[3][3],d[3][3];

int main()
{
    while (cin>>a>>b>>n>>m)
    {
        x[1][1]=(a+a)%m;    x[1][2]=(2*a*a+2*b)%m;
        memset(y,0,sizeof(y));
        c[1][1]=0;    c[1][2]=(m+(b-a*a)%m)%m;
        c[2][1]=1;    c[2][2]=(a+a)%m;
        e[1][1]=e[2][2]=1;
        e[1][2]=e[2][1]=0;
        for (int u=n-1;u;u>>=1)
        {
            if (u&1) 
            {
                memset(d,0,sizeof(d));
                for (int i=1;i<3;i++)
                    for (int j=1;j<3;j++)
                        for (int k=1;k<3;k++)
                            (d[i][k]+=c[i][j]*e[j][k])%=m;
                memcpy(e,d,sizeof(d));
            };
            memset(d,0,sizeof(d));
            for (int i=1;i<3;i++)
                    for (int j=1;j<3;j++)
                        for (int k=1;k<3;k++)
                            (d[i][k]+=c[i][j]*c[j][k])%=m;
            memcpy(c,d,sizeof(d));
        }
        for (int i=1;i<2;i++)
            for (int j=1;j<3;j++)
                for (int k=1;k<3;k++)
                    (y[i][k]+=x[i][j]*e[j][k])%=m;
        cout<<y[1][1]<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值