Description
Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.
Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.
Input
Lines 2.. M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)
Output
Sample Input
2 3 1 1 1 0 1 0
Sample Output
9
Hint
1 2 3 4
There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.
简单状压dp
#include<stack>
#include<queue>
#include<cmath>
#include<cstdio>
#include<vector>
#include<string>
#include<cstdlib>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long LL;
const int base=100000000;
const int maxn=105;
int n,m,a[maxn],b[1<<13],f[maxn][1<<13],x,N,ans;
int main()
{
for (int i=0;i<(1<<13);i++)
{
if (i&(i<<1)) b[i]=0;
else b[i]=1;
}
while (~scanf("%d%d",&n,&m))
{
N=1<<m;
for (int i=1;i<=n;i++)
for (int j=a[i]=0;j<m;j++)
{
scanf("%d",&x);
a[i]=a[i]|((1-x)<<j);
}
memset(f,0,sizeof(f));
f[0][0]=1;
for (int i=1;i<=n;i++)
for (int j=0;j<N;j++)
if ((!(a[i]&j))&&b[j])
for (int k=0;k<N;k++)
if (!(j&k)) (f[i][j]+=f[i-1][k])%=base;
ans=0;
for (int i=0;i<N;i++) (ans+=f[n][i])%=base;
printf("%d\n",ans);
}
return 0;
}
重温一遍
#include<set>
#include<map>
#include<ctime>
#include<cmath>
#include<stack>
#include<queue>
#include<bitset>
#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<functional>
#define rep(i,j,k) for (int i = j; i <= k; i++)
#define per(i,j,k) for (int i = j; i >= k; i--)
#define loop(i,j,k) for (int i = j;i != -1; i = k[i])
#define lson x << 1, l, mid
#define rson x << 1 | 1, mid + 1, r
#define fi first
#define se second
#define mp(i,j) make_pair(i,j)
#define pii pair<int,int>
using namespace std;
typedef long long LL;
const int low(int x) { return x&-x; }
const double eps = 1e-8;
const int INF = 0x7FFFFFFF;
const int mod = 1e8;
const int N = 1e3 + 10;
const int read()
{
char ch = getchar();
while (ch<'0' || ch>'9') ch = getchar();
int x = ch - '0';
while ((ch = getchar()) >= '0'&&ch <= '9') x = x * 10 + ch - '0';
return x;
}
int n, m, x, y;
int f[15][1 << 12];
int main()
{
while (scanf("%d%d", &n, &m) != EOF)
{
f[0][0] = 1;
int ans = 0;
rep(i, 1, n)
{
y = 0;
rep(j, 0, m - 1) x = read(), y |= x << j;
rep(j, 0, (1 << m) - 1)
{
if (((j & y) ^ j) || (j&(j << 1))) { f[i][j] = 0; continue; }
f[i][j] = 0;
rep(k, 0, (1 << m) - 1)
{
if ((j & k) || (k&(k << 1))) continue;
(f[i][j] += f[i - 1][k]) %= mod;
}
if (i == n) (ans += f[i][j]) %= mod;
}
}
printf("%d\n", ans);
}
return 0;
}