HDU 1542 Atlantis

Problem Description
There are several ancient Greek texts that contain descriptions of the fabled island Atlantis. Some of these texts even include maps of parts of the island. But unfortunately, these maps describe different regions of Atlantis. Your friend Bill has to know the total area for which maps exist. You (unwisely) volunteered to write a program that calculates this quantity.
 

Input
The input file consists of several test cases. Each test case starts with a line containing a single integer n (1<=n<=100) of available maps. The n following lines describe one map each. Each of these lines contains four numbers x1;y1;x2;y2 (0<=x1<x2<=100000;0<=y1<y2<=100000), not necessarily integers. The values (x1; y1) and (x2;y2) are the coordinates of the top-left resp. bottom-right corner of the mapped area.

The input file is terminated by a line containing a single 0. Don’t process it.
 

Output
For each test case, your program should output one section. The first line of each section must be “Test case #k”, where k is the number of the test case (starting with 1). The second one must be “Total explored area: a”, where a is the total explored area (i.e. the area of the union of all rectangles in this test case), printed exact to two digits to the right of the decimal point.

Output a blank line after each test case.
 

Sample Input
  
  
2 10 10 20 20 15 15 25 25.5 0
 

Sample Output
  
  
Test case #1 Total explored area: 180.00

矩形面积并模板题

#include<cstdio>
#include<cmath>
#include<map>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long LL;
const int maxn = 400005;
int n, m, tt = 0;
double l, r, a[maxn], ans;
struct seg
{
	double h, l, r;
	int k;
	bool operator <(const seg&a)
	{
		return h < a.h;
	}
}p[maxn];

struct ST
{
	double dis[maxn];
	int sum[maxn];
	void build(int x, int l, int r)
	{
		sum[x] = dis[x] = 0;
		if (l == r) return;
		else
		{
			int mid = l + r >> 1;
			build(x + x, l, mid);
			build(x + x + 1, mid + 1, r);
		}
	}
	void insert(int x, int l, int r, int ll, int rr, int v)
	{
		if (ll <= l&&r <= rr)
		{
			if (v < 0 && sum[x] == 0) goto next;
			sum[x] += v;
			if (sum[x]) dis[x] = a[r + 1] - a[l];
			else 
			{
				if(l==r) dis[x]=0;
				else dis[x] = dis[x + x] + dis[x + x + 1];
}
		}
		else
		{
			next:
			int mid = l + r >> 1;
			if (sum[x])
			{
				insert(x + x, l, mid, l, r, sum[x]);
				insert(x + x + 1, mid + 1, r, l, r, sum[x]);
				sum[x] = 0;
			}
			if (ll <= mid) insert(x + x, l, mid, ll, rr, v);
			if (rr > mid) insert(x + x + 1, mid + 1, r, ll, rr, v);
			dis[x] = dis[x + x] + dis[x + x + 1];
		}
	}
}st;

int main()
{
	while (scanf("%d", &n), n)
	{
		for (int i = 1; i <= n; i++)
		{
			scanf("%lf%lf%lf%lf", &l, &p[i + i - 1].h, &r, &p[i + i].h);
			p[i + i - 1].l = p[i + i].l = a[i + i - 1] = l;
			p[i + i - 1].r = p[i + i].r = a[i + i] = r;
			p[i + i - 1].k = 1;		   p[i + i].k = -1;
		}
		sort(a + 1, a + n + n + 1);
		m = unique(a + 1, a + n + n + 1) - a;
		sort(p + 1, p + n + n + 1);
		ans = 0;	st.build(1, 1, m - 2);
		for (int i = 1; i <= n + n; i++)
		{
			int u = lower_bound(a + 1, a + m, p[i].l) - a;
			int v = lower_bound(a + 1, a + m, p[i].r) - a;
			st.insert(1, 1, m - 2, u, v - 1, p[i].k);
			ans += (p[i + 1].h - p[i].h)*st.dis[1];
		}
		printf("Test case #%d\nTotal explored area: %.2lf\n\n", ++tt, ans);
	} 
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值