HUST 1544 R(N)

Description

We know that some positive integer x can be expressed as x=A^2+B^2(A,B are integers). Take x=10 for example, 10=(-3)^2+1^2.
We define R(N) (N is positive) to be the total number of variable presentation of N. So R(1)=4, which consists of 1=1^2+0^2, 1=(-1)^2+0^2, 1=0^2+1^2, 1=0^2+(-1)^2.Given N, you are to calculate R(N).

Input

No more than 100 test cases. Each case contains only one integer N(N<=10^9).

Output

For each N, print R(N) in one line.

Sample Input

2
6
10
25
65

Sample Output

4
0
8
12
16

Hint

For the fourth test case, (A,B) can be (0,5), (0,-5), (5,0), (-5,0), (3,4), (3,-4), (-3,4), (-3,-4), (4,3) , (4,-3), (-4,3), (-4,-3)

map预处理+枚举

#include<string>
#include<algorithm>
#include<iostream>
#include<cstring>
#include<cstdio>
#include<queue>
#include<map>
#include<cmath>
using namespace std;
const int maxn = 10 + 5;
typedef long long LL;
int T, n, m;
map<int, int> M;

int main()
{
	for (int i = 0; i*i <= 1e9; i++)
	{
		M[i*i] = 1;
	}
	while (scanf("%d", &n) != EOF)
	{
		LL ans = 0;
		for (int i = 0; i*i <= n; i++)
		{
			if (M[n - i*i])
			{
				int t = 4;
				if (i == 0) t /= 2;
				if (n == i*i) t /= 2;
				ans += t;
			}
		}
		cout << ans << endl;
	}
	//while (scanf("%d", &n) != EOF){}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值