HUST 1339 Reversal

Description

You will get line with some words(only lowercase and uppercase, no other characters), input it and make all the word reversal and output.

Input

The first line is a number T means there are T cases. For each case: The first line is N means next line has N words. All the words in a line and between two words only one blank. (No more than 100 words, and each word length not exceeded 10)

Output

For each case, output a line with the reversal word in the input order.  Between two words has exact one blank, but DO NOT output an blank at the end of a line.

Sample Input

3
4
I am a man
4
I will AC it
3
I love ACM

Sample Output

I ma a nam
I lliw CA ti

I evol MCA

#include<string>
#include<algorithm>
#include<iostream>
#include<cstring>
#include<cstdio>
#include<queue>
#include<map>
#include<cmath>
using namespace std;
const int maxn = 10 + 5;
typedef long long LL;
int T, n, m;
char s[maxn];

int main()
{
	scanf("%d", &T);
	while (T--)
	{
		scanf("%d", &n);
		while (n--)
		{
			scanf("%s", s);
			for (int i = strlen(s); i; i--) printf("%c", s[i - 1]);
			if (n) printf(" "); else printf("\n");
		}
	}
	//while (scanf("%d", &n) != EOF){}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值