PAT (Advanced Level) Practise 1068 Find More Coins (30)

1068. Find More Coins (30)

时间限制
150 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she must pay the exact amount. Since she has as many as 104 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find some coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (<=104, the total number of coins) and M(<=102, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the face values V1 <= V2 <= ... <= Vk such that V1 + V2 + ... + Vk = M. All the numbers must be separated by a space, and there must be no extra space at the end of the line. If such a solution is not unique, output the smallest sequence. If there is no solution, output "No Solution" instead.

Note: sequence {A[1], A[2], ...} is said to be "smaller" than sequence {B[1], B[2], ...} if there exists k >= 1 such that A[i]=B[i] for all i < k, and A[k] < B[k].

Sample Input 1:
8 9
5 9 8 7 2 3 4 1
Sample Output 1:
1 3 5
Sample Input 2:
4 8
7 2 4 3
Sample Output 2:

No Solution


直接dfs+剪枝就可以过的,当然如果用dp啊也是可以的。然而搞笑的是,之前还没在甲级里做这题,在那个团体程序设计天梯赛-练习集看到的,结果题目数据描述有问题,

那个数字m直接写的是10^42,一开始我也是先上了个简单的dfs,结果有个点wa了,然后改了大数结果过了。我以为题目真的是大数的,现在才发现,其实我改了个判断条件。。

#include<cstdio>
#include<stack>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 1e5 + 10;
typedef long long LL;
stack<int> ans;
int n, a[maxn], m, sum[maxn];

bool dfs(int x, int y)
{
	if (y == m) return true;
	if (x > n || y + sum[x] < m || y > m) return false;
	if (dfs(x + 1, y + a[x]))
	{
		ans.push(a[x]);
		return true;
	}
	if (dfs(x + 1, y)) return true;
	return false;
}

int main()
{
	scanf("%d%d", &n, &m);
	for (int i = 1; i <= n; i++) scanf("%d", &a[i]);
	sort(a + 1, a + n + 1);
	for (int i = n; i; i--) sum[i] = sum[i + 1] + a[i];
	if (!dfs(1, 0)) printf("No Solution\n");
	else
	{
		while (!ans.empty())
		{
			printf("%d", ans.top());
			ans.pop();
			if (ans.empty()) printf("\n"); else printf(" ");
		}
	}
	return 0;
}

大数版,果然不能太高看pat的题目啊。。。

#include<cstdio>
#include<string>
#include<stack>
#include<vector>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn = 1e5 + 10;
typedef long long LL;
string s;
int n;

struct bignum
{
  vector<int> v;
  void read()
  {
    cin >> s;
    for (int i = s.size() - 1; i >= 0; i--) v.push_back(s[i] - '0');
  }
  void write()
  {
    for (int i = v.size() - 1; i >= 0; i--) printf("%d", v[i]);
  }
  bool operator<(const bignum&a) const
  {
    if (v.size() == a.v.size())
    {
      for (int i = a.v.size() - 1; i >= 0; i--)
      {
        if (a.v[i] == v[i]) continue;
        return v[i] < a.v[i];
      }
      return false;
    }
    else return v.size() < a.v.size();
  }
}m, sum[maxn], a[maxn], zero;

bignum operator+(const bignum&a, const bignum &b)
{
  bignum c;  int j = 0;
  for (int i = 0; i < max(a.v.size(), b.v.size()); i++)
  {
    int x = i < a.v.size() ? a.v[i] : 0;
    int y = i < b.v.size() ? b.v[i] : 0;
    c.v.push_back((x + y + j) % 10);
    j = (x + y + j) / 10;
  }
  if (j) c.v.push_back(j);
  return c;
}

int cmp(const bignum&a, const bignum &b)
{
  if (a.v.size() == b.v.size())
  {
    for (int i = a.v.size() - 1; i >= 0; i--)
    {
      if (a.v[i] == b.v[i]) continue;
      return a.v[i] - b.v[i];
    }
    return 0;
  }
  else return a.v.size() - b.v.size();
}

stack<bignum> ans;

bool dfs(int x, bignum y)
{
  if (!cmp(y, m)) return true;
  if (x > n || cmp(y + sum[x], m) < 0 || cmp(y, m) > 0) return false;
  if (dfs(x + 1, y + a[x]))
  {
    ans.push(a[x]);
    return true;
  }
  if (dfs(x + 1, y)) return true;
  return false;
}

int main()
{
  scanf("%d", &n);  m.read();
  for (int i = 1; i <= n; i++) a[i].read();
  sort(a + 1, a + n + 1);
  for (int i = n; i; i--) sum[i] = sum[i + 1] + a[i];
  zero.v.push_back(0);
  if (!dfs(1, zero)) printf("No Solution\n");
  else
  {
    while (!ans.empty())
    {
      ans.top().write();
      ans.pop();
      if (ans.empty()) printf("\n"); else printf(" ");
    }
  }
  return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值