HDU 3006 The Number of set

Problem Description
Given you n sets.All positive integers in sets are not less than 1 and not greater than m.If use these sets to combinate the new set,how many different new set you can get.The given sets can not be broken.
 

Input
There are several cases.For each case,the first line contains two positive integer n and m(1<=n<=100,1<=m<=14).Then the following n lines describe the n sets.These lines each contains k+1 positive integer,the first which is k,then k integers are given. The input is end by EOF.
 

Output
For each case,the output contain only one integer,the number of the different sets you get.
 

Sample Input
  
  
4 4 1 1 1 2 1 3 1 4 2 4 3 1 2 3 4 1 2 3 4
 

Sample Output
  
  
15 2
简单状态压缩dp
#include<cmath>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long LL;
const double pi = acos(-1.0);
const int low(int x) { return x&-x; }
const int INF = 0x7FFFFFFF;
const int mod = 1e9 + 7;
const int maxn = 1e5 + 10;
int n, m, x, y, z;
int dp[maxn];

int main()
{
	while (scanf("%d%d", &n, &m) != EOF)
	{
		for (int i = dp[0] = 1; i < (1 << m); i++) dp[i] = 0;
		while (n--)
		{
			scanf("%d", &x);	z = 0;
			while (x--) { scanf("%d", &y); z |= 1 << y - 1; }
			for (int i = 0; i < (1 << m); i++) dp[i | z] = dp[i] | dp[i | z];
		}
		int ans = 0;
		for (int i = 1; i < (1 << m); i++) ans += dp[i];
		printf("%d\n", ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值