POJ 1742 Coins

Coins
Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 33625 Accepted: 11414

Description

People in Silverland use coins.They have coins of value A1,A2,A3...An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch. 
You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins. 

Input

The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.

Output

For each test case output the answer on a single line.

Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output

8

4

多重背包,各种优化的方案贴上。

二进制优化再加上一点小优化(缩小最内层循环的大小)

#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn = 1e5 + 10;
int n, m, l, r, x[maxn], y[maxn], z, dp[maxn];

int main()
{
	dp[0] = 1;
	while (scanf("%d%d", &n, &m), n + m)
	{
		l = 1;	r = m;
		for (int i = 1; i <= m; i++) dp[i] = 0;
		for (int i = 1; i <= n; i++) scanf("%d", &x[i]);
		for (int i = 1; i <= n; i++) scanf("%d", &y[i]);
		for (int i = 1; i <= n; i++)
		{
			for (int j = 1; y[i]; j <<= 1)
			{
				z = x[i] * min(j, y[i]);	y[i] -= min(y[i], j);
				for (int k = min(r, m); k >= max(l, z); k--) dp[k] |= dp[k - z];
			}
			while (dp[r] && r >= l) --r;
			while (dp[l] && l <= r) ++l;
		}
		int ans = 0;
		for (int i = 1; i <= m; i++) ans += dp[i];
		printf("%d\n", ans);
	}
	return 0;
}

另外一种优化方式

#include<queue>
#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn = 1e5 + 10;
int n, m, x[maxn], y[maxn], z, dp[maxn], f[maxn], ans;

int main()
{
	dp[0] = 1;
	while (scanf("%d%d", &n, &m), n + m)
	{
		for (int i = m; i; i--) ans = dp[i] = 0;
		for (int i = 1; i <= n; i++) scanf("%d", &x[i]);
		for (int i = 1; i <= n; i++) scanf("%d", &y[i]);
		for (int i = 1; i <= n; i++)
		{
			for (int j = 0; j <= m; j++) f[j] = 0;
			for (int j = x[i]; j <= m; j++)
			{
				if (!dp[j] && dp[j - x[i]] && f[j - x[i]] < y[i])
				{
					dp[j] = 1;	f[j] = f[j - x[i]] + 1;
				}
			}
		}
		for (int i = 1; i <= m; i++) ans += dp[i];
		printf("%d\n", ans);
	}
	return 0;
}

单调队列优化

#include<map>
#include<set>
#include<queue>
#include<stack>
#include<cmath>
#include<cstdio>
#include<bitset>
#include<string>
#include<vector>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<functional>
using namespace std;
typedef long long LL;
const int low(int x) { return x&-x; }
const int INF = 0x7FFFFFFF;
const int mod = 1e9 + 7;
const int maxn = 1e5 + 50;
int n, m;
int v[maxn], w[maxn];
int l, r, ll, rr;
int a[maxn];
int f[maxn];

int main()
{
	while (scanf("%d%d", &n, &m), n + m)
	{
		for (int i = 1; i <= n; i++) scanf("%d", &v[i]);
		for (int i = 1; i <= n; i++) scanf("%d", &w[i]);
		for (int i = f[0] = 1; i <= m; i++) f[i] = 0;
		for (int i = 1; i <= n; i++)
		{
			if (w[i] * v[i] >= m)
			{
				for (int j = v[i]; j <= m; j++) f[j] |= f[j - v[i]];
			}
			else if (w[i] == 1)
			{
				for (int j = m; j >= v[i]; j--) f[j] |= f[j - v[i]];
			}
			else
			{
				for (int j = 0; j < v[i]; j++)
				{
					l = 1; r = 0;
					for (int k = 0; j + k <= m; k += v[i])
					{
						if (l <= r && k - a[l] > v[i] * w[i]) l++;
						if (f[j + k]) a[++r] = k;
						else f[j + k] = l <= r;
 					}
				}
			}
		}
		int ans = 0;
		for (int i = 1; i <= m; i++) ans += f[i];
		printf("%d\n", ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值