POJ 1742 Coins (多重背包)

Coins
Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 28448 Accepted: 9645

Description

People in Silverland use coins.They have coins of value A1,A2,A3...An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.
You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.

Input

The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.

Output

For each test case output the answer on a single line.

Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output

8
4

Source

LouTiancheng@POJ
题目的意思:
第一行输入,n,m分别表示n种硬币,m表示总钱数。
第二行输入n个硬币的价值,和n个硬币的数量。
输出这些硬币能表示的所有在m之内的硬币种数。

代码:1297MS

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
using namespace std;
#define M 105
#define N 100005
int wight[M],cost[M],dp[N],user[N];
int main()
{
    int i,j,n,m,ans;
    while(scanf("%d%d",&n,&m)!=EOF &&n && m)
    {
        for(i=1;i<=n;i++) cin>>wight[i];
        for(i=1;i<=n;i++) cin>>cost[i];
        memset(dp,0,sizeof(dp));
        dp[0]=1;ans=0;
        for(i=1;i<=n;i++)
        {
            memset(user,0,sizeof(user));   //这里user表示的是这种钱币在到达某种状态时,用了多少。j表示要到达的状态,也就是钱的总额。
            for(j=wight[i];j<=m;j++)
            {    //如果该钱币总额状态没到过,而前一个状态到过,也就是说,只要加一个wight[i]表示的钱币就能到到该状态,
                 //而到达前一状态还剩这类钱币,就表示该状态可以到达。
                if(!dp[j] && dp[j-wight[i]] && user[j-wight[i]]+1<=cost[i]) 
                {
                    dp[j]=1;
                    user[j]=user[j-wight[i]]+1; //用一个钱币到达了该状态,这一个钱币当然要加上。
                    ans++;                      //能到达的钱币总额状态加一。
                }
            }
        }
        cout<<ans<<endl;
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值