HDU 5726 GCD

Problem Description
Give you a sequence of  N(N100,000)  integers :  a1,...,an(0<ai1000,000,000) . There are  Q(Q100,000)  queries. For each query  l,r  you have to calculate  gcd(al,,al+1,...,ar)  and count the number of pairs (l,r)(1l<rN) such that  gcd(al,al+1,...,ar)  equal  gcd(al,al+1,...,ar) .
 

Input
The first line of input contains a number  T , which stands for the number of test cases you need to solve.

The first line of each case contains a number  N , denoting the number of integers.

The second line contains  N  integers,  a1,...,an(0<ai1000,000,000) .

The third line contains a number  Q , denoting the number of queries.

For the next  Q  lines, i-th line contains two number , stand for the  li,ri , stand for the i-th queries.
 

Output
For each case, you need to output “Case #:t” at the beginning.(with quotes,  t  means the number of the test case, begin from 1).

For each query, you need to output the two numbers in a line. The first number stands for  gcd(al,al+1,...,ar)  and the second number stands for the number of pairs (l,r)  such that  gcd(al,al+1,...,ar)  equal  gcd(al,al+1,...,ar) .
 

Sample Input
  
  
1 5 1 2 4 6 7 4 1 5 2 4 3 4 4 4
 

Sample Output
  
  
Case #1: 1 8 2 4 2 4 6 1
 
先预处理出以i为开头的区间的各自的gcd值,用线段树维护区间gcd和查询,然后询问的时候直接输出即可。

#include<set>
#include<map>
#include<cmath>
#include<stack>
#include<queue>
#include<bitset>
#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<functional>
#define rep(i,j,k) for (int i = j; i <= k; i++)
#define per(i,j,k) for (int i = j; i >= k; i--)
using namespace std;
typedef long long LL;
const int low(int x) { return x&-x; }
const int N = 4e5 + 10;
const int mod = 1e9 + 7;
const int INF = 0x7FFFFFFF;
int T, n, m, g[N], a[N], l, r, q, cas = 0;
map<int, LL> M;

int gcd(int x, int y) { return x%y ? gcd(y, x%y) : y; }

void build(int x, int l, int r)
{
    if (l == r) scanf("%d", &g[x]), a[l] = g[x];
    else
    {
        int mid = l + r >> 1;
        build(x << 1, l, mid);
        build(x << 1 | 1, mid + 1, r);
        g[x] = gcd(g[x << 1], g[x << 1 | 1]);
    }
}

int get(int x, int l, int r, int ll, int rr)
{
    if (ll <= l&&r <= rr) return g[x];
    int mid = l + r >> 1;
    int x1 = 0, x2 = 0;
    if (ll <= mid) x1 = get(x << 1, l, mid, ll, rr);
    if (rr > mid) x2 = get(x << 1 | 1, mid + 1, r, ll, rr);
    return gcd(min(x1, x2), max(x1, x2));
}

bool find(int x, int l, int r, int ll, int rr, int u, int &v)
{
    if (ll <= l && r <= rr)
    {
        if (gcd(v, g[x]) < u)
        {
            if (l == r)
            {
                q = l; return true;
            }
            else
            {
                int mid = l + r >> 1;
                if (find(x<<1, l, mid, ll, rr, u, v)) return true;
                if (find(x<<1|1, mid + 1, r, ll, rr, u, v)) return true;
            }
        }
        else { v = gcd(v, g[x]); return false; }
    }
    else
    {
        int mid = l + r >> 1;
        if (ll <= mid&&find(x<<1, l, mid, ll, rr, u, v)) return true;
        if (rr > mid&& find(x<<1|1, mid + 1, r, ll, rr, u, v)) return true;
        return false;
    }
}

int main()
{
    scanf("%d", &T);
    while (T--)
    {
        M.clear();
        scanf("%d", &n);
        build(1, 1, n);
        for (int i = 1, j, k; i <= n; i++)
        {
            int kk = get(1, 1, n, i, n);
            for (k = i, j = a[i]; k <= n;)
            {
                if (kk == j) { M[j] += n - k + 1; break; }
                int gg = a[i];
                find(1, 1, n, i, n, j, gg);
                M[j] += q - k;
                k = q;    j = gcd(a[q], j);
            }
        }
        scanf("%d", &m);
        printf("Case #%d:\n", ++cas);
        while (m--)
        {
            scanf("%d%d", &l, &r);
            int x = get(1, 1, n, l, r);
            printf("%d %lld\n", x, M[x]);
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值