HDU 5875 Function

Problem Description
The shorter, the simpler. With this problem, you should be convinced of this truth.
  
  You are given an array  A  of  N  postive integers, and  M  queries in the form  (l,r) . A function  F(l,r) (1lrN)  is defined as:
F(l,r)={AlF(l,r1) modArl=r;l<r.
You job is to calculate  F(l,r) , for each query  (l,r) .
 

Input
There are multiple test cases.
  
  The first line of input contains a integer  T , indicating number of test cases, and  T  test cases follow. 
  
  For each test case, the first line contains an integer  N(1N100000) .
  The second line contains  N  space-separated positive integers:  A1,,AN (0Ai109) .
  The third line contains an integer  M  denoting the number of queries. 
  The following  M  lines each contain two integers  l,r (1lrN) , representing a query.
 

Output
For each query (l,r) , output  F(l,r)  on one line.
 

Sample Input
  
  
1 3 2 3 3 1 1 3
 

Sample Output
  
  
2
求一个区间最左端的数对于右端的全部数字取模,由于每次取模至少减半,所以取模的次数不会很多,
用线段树来寻找右端小于等于当前值的第一个数字即可。
#include<set>
#include<map>
#include<ctime>
#include<cmath>
#include<stack>
#include<queue>
#include<bitset>
#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<functional>
#define rep(i,j,k) for (int i = j; i <= k; i++)
#define per(i,j,k) for (int i = j; i >= k; i--)
#define loop(i,j,k) for (int i = j;i != -1; i = k[i])
#define lson x << 1, l, mid
#define rson x << 1 | 1, mid + 1, r
#define ff first
#define ss second
#define mp(i,j) make_pair(i,j)
#define pb push_back
#define pii pair<int,int>
#define in(x) scanf("%d", &x);
using namespace std;
typedef long long LL;
const int low(int x) { return x&-x; }
const double eps = 1e-8;
const int INF = 0x7FFFFFFF;
const int mod = 1e9 + 7;
const int N = 1e5 + 10;
int T, n, m,l,r;
int a[N],f[N<<2];

void build(int x,int l,int r)
{
    if (l==r) {in(f[x]); a[l]=f[x];}
    else 
    {
        int mid=l+r>>1;
        build(lson); build(rson);
        f[x]=min(f[x<<1],f[x<<1|1]);
    }
}

int find(int x,int l,int r,int ll,int rr,int u)
{
    if (f[x] > u) return rr+1;
    if (ll<=l&&r<=rr)
    {
        if (l==r) return l;
        int mid=l+r>>1;
        if (f[x<<1]<=u) return find(lson,ll,rr,u);
        else return find(rson,ll,rr,u);
    }
    else 
    {
        int mid=l+r>>1,res;
        if (ll<=mid)
        {
            res=find(lson,ll,rr,u);
            if (res<=rr) return res;
        }
        if (rr>mid) 
        {
            res=find(rson,ll,rr,u);
            if (res<=rr) return res;
        }
        return rr+1;
    }
}

int main()
{
    in(T);
    while (T--)
    {
        scanf("%d",&n);
        build(1,1,n);
        scanf("%d",&m);
        while (m--)
        {
            scanf("%d%d",&l,&r);
            int ans=a[l];
            while (l < r)
            {
                int q = find(1,1,n,l+1,r,ans);
                if (q<=r) ans%=a[q];    l=q;
            }
            printf("%d\n",ans);
        }
    }
    return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值