ZOJ 1608 Two Circles and a Rectangle

Give you two circles and a rectangle, your task is to judge wheather the two circles can be put into the rectangle with no part of circles outside the retangle.


Input

There are multiple test cases. In every test cast, there are four float-point numbers:

a, b, r1, r2

where, a and b are two sides of the rectangle, r1 and r2 are radii of the two circls.


Output

Print a "Yes", if the circles can be put into the rectangle. Otherwise, print a "No".

You can safely assume x < y, where x and y are float-point numbers, if x < y + 0.01.


Sample Input

5 4 1 1
5 4 1.5 2


Sample Output

Yes
No


一个矩形里放两个圆,显然一个放左上一个放右下,然后判断是否可行即可。

#include<bits/stdc++.h>
using namespace std;
const int N=1e5+10;
float a,b,r1,r2;

int main()
{
    while(~scanf("%f%f%f%f",&a,&b,&r1,&r2))
    {
        if (a<r1+r1+0.01||b<r1+r1+0.01) {puts("No"); continue;}
        if (a<r2+r2+0.01||b<r2+r2+0.01) {puts("No"); continue;}
        float x=a-r1-r2,y=b-r1-r2;
        if (sqrt(x*x+y*y)<r1+r2+0.01) puts("No");
        else puts("Yes");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值