HDU 6011

Lotus and Characters

Lotus has n kinds of characters,each kind of characters has a value and a amount.She wants to construct a string using some of these characters.Define the value of a string is:its first character's value*1+its second character's value *2+...She wants to calculate the maximum value of string she can construct.
Since it's valid to construct an empty string,the answer is always 0。

Input

First line is T(0T1000)
denoting the number of test cases.
For each test case,first line is an integer n(1n26) ,followed by n lines each containing 2 integers vali,cnti(|vali|,cnti100)
,denoting the value and the amount of the ith character.


Output
For each test case.output one line containing a single integer,denoting the answer.
Sample Input
2
2
5 1
6 2
3
-5 3
2 1
1 1
Sample Output
35
5

          

解释一下测试数据:每次的价值数据都要先进行排序,选出价值大的放在前面

比如第一组测试数据 5 1    6 2;显然6的价值更高,因此把6放在后面,就是6*2+6*3;再是5,就是5*1,结果就为35,再是第二组数据:排好序后就变成2  1  -5;

应该就是2*2+1*1=5;如果是2*3+1*2+(-5)*1的话值是小于0的,因此-5数据直接舍弃了。

已经AC过的代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
pair<int,int> p[35];
int main()
{
    int t,n,v,c;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            scanf("%d %d",&v,&c);
            p[i]=make_pair(v,c);
        }
        long long sum=0;
        long long ans=0;
        sort(p,p+n);
        for(int i=n-1;i>=0;i--)
        {
            for(int j=0;j<p[i].second;j++)
            {
                ans+=p[i].first;
                if(ans<0)
                    break;
                sum+=ans;
            }
        }
        cout<<sum<<'\n';
    }
    return 0;
}
//用到了一些pair函数的使用,此前的博客里已经说明过了怎么使用。                                                       

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值