大整数的因子

描述

已知正整数k满足2≤k≤9,现给出长度最大为30位的十进制非负整数c,求所有能整除c的k。

格式

输入格式

一个非负整数c,c的位数≤30。

输出格式

若存在满足 c%k == 0 的k,从小到大输出所有这样的k,相邻两个数之间用单个空格隔开;若没有这样的k,则输出"none"。

样例

输入样例

30

输出样例

2 3 5 6

 

#include <iostream>
#include <stdio.h>
#include <cstring>  
#include <stdio.h>
#include <algorithm>
#include <cmath>
using namespace std;
//#define N 10001



int main(){	

	char arr[31];
	
	cin>>arr;
	
	int len = strlen(arr);

	int flag = 0, t = 0; 
	for(int k=2; k<10; ++k){
		t = 0;
		for(int i=0; i<len; ++i){
			t = arr[i] - '0' + t*10;
//			printf("t = %d\n", t);
			if (t >= k || t == 0){
				t = t%k;
				if(t == 0 && i==len-1){
					printf("%d ",k);
					flag = 1;
				}
			}else{				
				if(i+1 < len){					
					t = t*10 + arr[++i]-'0';
//					printf("ab %d \n",t);
					t = t%k;
//					printf("abc %d \n",t);
					if(t == 0 && i==len-1){
						printf("%d ",k);
						flag = 1;
					}
				}else{
					break;
				}				
			}
		}		
	}
	if(flag == 0){
		printf("none");
	}
	
	return 0;

}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值