POJ1426: Find The Multiple(bfs,同余定理)

Find The Multiple
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 28780 Accepted: 11935 Special Judge

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111
大意是给出一个数n,求出n的一个仅含0或1的倍数。

这是稍微暴力地深搜

# include <stdio.h>
int n, flag;
unsigned long long result;
void dfs(int step, unsigned long long sum)
{
    int i;
    if(sum % n == 0)
    {
        flag = 1;
        result = sum;
        return;
    }
    if(step == 19)
        return;
    for(i=0; i<=1; ++i)
    {
        sum = sum*10 + i;
        dfs(step+1, sum);
        sum = (sum-i)/10;
        if(flag)
            return;
    }
}
int main()
{
    while(scanf("%d",&n), n)
    {
        flag = 0;
        dfs(1, 1);
        printf("%llu\n",result);
    }
    return 0;
}


这是广搜的做法

# include <stdio.h>
# include <string.h>
struct node
{
    int num, pre, sum;//pre记录父节点的下标
}a[300];
int main()
{
    int b[300], vis[300], n, i, k, temp, head, tail, flag, result;
    while(scanf("%d",&n),n)
    {
        memset(a, 0, sizeof(a));
        memset(b, 0, sizeof(b));
        memset(vis, 0, sizeof(vis));
        k = flag = head = tail = 0;
        a[head].num = 1;
        a[head].sum = 1;
        a[head].pre = -1;
        while(head <= tail)
        {
            for(i=0; i<=1; ++i)
            {
                temp = (a[head].sum * 10 + i)%n;//同余定理
                if(!vis[temp])//★排除重复的情况
                {
                    ++tail;
                    a[tail].pre = head;
                    a[tail].num = i;
                    a[tail].sum = temp;
                    vis[temp] = 1;
                }
                if(a[tail].sum == 0)
                {
                    result = tail;
                    flag = 1;
                    break;
                }
            }
            if(flag)
                break;
            ++head;
        }
        while(a[result].pre != -1)//将路线节点的下标找出来
        {
            b[k++] = a[result].pre;
            result = a[result].pre;
        }
        --k;
        for(i=k; i>=0; --i)//将找出来的下标输出对应的值
        {
            printf("%d",a[b[i]].num);
        }
        printf("%d\n",a[tail].num);
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值