poj 1426 Find The Multiple(bfs+同余定理)

Find The Multiple
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 26925 Accepted: 11173 Special Judge

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111
题意:求一个n的倍数,这个数都由0和1组成,输入保证存在这样的数

思路:利用同余定理去bfs即可~

36xxxxxx的结果跟60xxxxxxx的结果对24取模是一样的,所以我们加了36就没必要去加60了

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
using namespace std;
int n,vis[210];
struct Node
{
    string s;
    int m,k;
};
string bfs()
{
    Node a,next;
    a.s="";
    a.m=0,a.k=0;
    int t=-1;
    queue<Node>que;
    que.push(a);
    while(!que.empty())
    {
        Node now=que.front();
        que.pop();
        if(!now.m&&t>-1)
            return now.s;
        if(now.k>t)
        {
            t=now.k;
            memset(vis,0,sizeof(vis));
        }
        next.s=now.s+"0";
        next.m=now.m*10%n;
        next.k=now.k+1;
        if(!vis[next.m]&&next.k>1)
        {
            vis[next.m]=1;
            que.push(next);
        }

        next.s=now.s+"1";
        next.m=(now.m*10+1)%n;
        next.k=now.k+1;
        if(!vis[next.m])
        {
            vis[next.m]=1;
            que.push(next);
        }
    }
}
int main()
{
    while(~scanf("%d",&n)&&n)
    {
        if(!n)
        {
            printf("0\n");
            continue;
        }
        cout<<bfs()<<endl;
    }
    return 0;
}






  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值