HDU4737:A Bit Fun(二分)

A Bit Fun

Time Limit: 5000/2500 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3079    Accepted Submission(s): 1535


Problem Description
There are n numbers in a array, as a 0, a 1 ... , a n-1, and another number m. We define a function f(i, j) = a i|a i+1|a i+2| ... | a j . Where "|" is the bit-OR operation. (i <= j)
The problem is really simple: please count the number of different pairs of (i, j) where f(i, j) < m.
 

Input
The first line has a number T (T <= 50) , indicating the number of test cases.
For each test case, first line contains two numbers n and m.(1 <= n <= 100000, 1 <= m <= 2 30) Then n numbers come in the second line which is the array a, where 1 <= a i <= 2 30.
 

Output
For every case, you should output "Case #t: " at first, without quotes. The  t is the case number starting from 1.
Then follows the answer.
 

Sample Input
  
  
2 3 6 1 3 5 2 4 5 4
 

Sample Output
  
  
Case #1: 4 Case #2: 0
 

Source

2013 ACM/ICPC Asia Regional Chengdu Online


题意:求有多少个子区间满足区间内的数按位或结果小于m。

思路:a[i][j]表示前i个数二进制第j位有多少个1,然后二分即可。

# include <stdio.h>
# include <string.h>
# define MAXN 100000

int a[MAXN+1][36];
int judge(int i, int mid)
{
    int sum = 0;
    for(int j=0; j<36; ++j)
        if(a[mid][j]-a[i-1][j])
            sum |= (1<<j);
    return sum;
}

int main()
{
    int t, n, m, num,cas=1;
    scanf("%d",&t);
    while(t--)
    {
        long long ans = 0;
        memset(a, 0, sizeof(a));
        scanf("%d%d",&n,&m);
        for(int i=1; i<=n; ++i)
        {
            int len = 0;
            scanf("%d",&num);
            for(int j=0; j<36; ++j)
                a[i][j] += a[i-1][j];
            while(num)
            {
                a[i][len++] += num&1;
                num >>= 1;
            }
        }
        for(int i=1; i<=n; ++i)
        {
            int l = i;
            int r = n;
            while(l <= r)
            {
                int mid = (l+r)>>1;
                if(judge(i, mid) < m)
                    l = mid + 1;
                else
                    r = mid - 1;
            }
            ans += r - i + 1;
        }
        printf("Case #%d: %lld\n",cas++,ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值