POJ3579:Median(二分)

Median
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6929 Accepted: 2321

Description

Given N numbers, X1X2, ... , XN, let us calculate the difference of every pair of numbers: ∣Xi - Xj∣ (1 ≤ i  j  N). We can get C(N,2) differences through this work, and now your task is to find the median of the differences as quickly as you can!

Note in this problem, the median is defined as the (m/2)-th  smallest number if m,the amount of the differences, is even. For example, you have to find the third smallest one in the case of = 6.

Input

The input consists of several test cases.
In each test case, N will be given in the first line. Then N numbers are given, representing X1X2, ... , XN, ( X≤ 1,000,000,000  3 ≤ N ≤ 1,00,000 )

Output

For each test case, output the median in a separate line.

Sample Input

4
1 3 2 4
3
1 10 2

Sample Output

1
8

Source

题意:给出n个数,将他们的两两差值排序,找到中位数。

思路:二分答案+二分判断。

# include <iostream>
# include <cstdio>
# include <algorithm>

using namespace std;
int a[100001];
long long n, tar;

bool fun(int x)
{
    long long sum = 0;
    for(int i=0; i<n-1; ++i)
    {
        int pos = upper_bound(a+i, a+n, a[i]+x)-a;
        sum += pos - i - 1;
        if(sum >= tar)
            return true;
    }
    return false;
}
int main()
{
    while(~scanf("%lld",&n))
    {
        for(int i=0; i<n; ++i)
            scanf("%d",&a[i]);
        long long tmp = n*(n-1)>>1;
        if(tmp&1)
            tar = (tmp>>1)+1;
        else
            tar = tmp>>1;
        sort(a, a+n);
        int l=0, r=a[n-1]-a[0], mid;
        while(l<r)
        {
            int mid = (l + r)>>1;
            if(fun(mid))
                r = mid;
            else
                l = mid+1;
        }
        printf("%d\n",r);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值