AtCoder:Median Pyramid Hard(思维)

传送门:点击打开链接

D - Median Pyramid Hard


Time limit : 2sec / Memory limit : 256MB

Score : 1300 points

Problem Statement

We have a pyramid with N steps, built with blocks. The steps are numbered 1 through N from top to bottom. For each 1iN, step i consists of 2i1 blocks aligned horizontally. The pyramid is built so that the blocks at the centers of the steps are aligned vertically.

A pyramid with N=4 steps

Snuke wrote a permutation of (122N1) into the blocks of step N. Then, he wrote integers into all remaining blocks, under the following rule:

  • The integer written into a block b must be equal to the median of the three integers written into the three blocks directly under b, or to the lower left or lower right of b.

Writing integers into the blocks

Afterwards, he erased all integers written into the blocks. Now, he only remembers that the permutation written into the blocks of step N was (a1a2a2N1).

Find the integer written into the block of step 1.

Constraints

  • 2N105
  • (a1a2a2N1) is a permutation of (122N1).

Input

The input is given from Standard Input in the following format:

N
a1 a2  a2N1

Output

Print the integer written into the block of step 1. v


Sample Input 1

Copy
4
1 6 3 7 4 5 2

Sample Output 1

Copy
4

This case corresponds to the figure in the problem statement.


Sample Input 2

Copy
2
1 2 3

Sample Output 2

Copy
2
题意:给出金字塔的底部数列,上一个砖块是下面三个的中位数,求最顶部砖块的数字。

思路:这里 二分答案,转换成01串,两个相连的0和1可以一直往上推,据此二分即可。

# include <stdio.h>
int a[200000+3], n;
bool small(int i, int j, int k) {return a[i]<=k && a[j]<=k;}
bool big(int i, int j, int k) {return a[i]>k && a[j]>k;}
bool judge(int k)
{
    for(int i=0; i<n-1; ++i)
    {
        if(big(n+i, n+i+1, k) || big(n-i, n-i-1, k)) return false;
        if(small(n+i, n+i+1, k) || small(n-i, n-i-1, k)) return true;
    }
    return small(1,1,k);
}
int main()
{
    scanf("%d",&n);
    for(int i=1; i<n<<1; ++i)
        scanf("%d",&a[i]);
    int l=1, r=(n<<1)-1, mid;
    while(l < r)
    {
        mid = l+r>>1;
        if(judge(mid))
            r = mid;
        else
            l = mid + 1;
    }
    printf("%d\n",r);
    return 0;
}



  • 2
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值