AtCoder:Median Pyramid Easy(思维)

B - Median Pyramid Easy


Time limit : 2sec / Memory limit : 256MB

Score : 400 points

Problem Statement

We have a pyramid with N steps, built with blocks. The steps are numbered 1 through N from top to bottom. For each 1iN, step i consists of 2i1 blocks aligned horizontally. The pyramid is built so that the blocks at the centers of the steps are aligned vertically.

A pyramid with N=4 steps

Snuke wrote a permutation of (122N1) into the blocks of step N. Then, he wrote integers into all remaining blocks, under the following rule:

  • The integer written into a block b must be equal to the median of the three integers written into the three blocks directly under b, or to the lower left or lower right of b.

Writing integers into the blocks

Afterwards, he erased all integers written into the blocks. Now, he only remembers that the integer written into the block of step 1 was x.

Construct a permutation of (122N1) that could have been written into the blocks of step N, or declare that Snuke's memory is incorrect and such a permutation does not exist.

Constraints

  • 2N105
  • 1x2N1

Input

The input is given from Standard Input in the following format:

N x

Output

If no permutation of (122N1) could have been written into the blocks of step N, print No.

Otherwise, print Yes in the first line, then print 2N1 lines in addition.

The i-th of these 2N1 lines should contain the i-th element of a possible permutation.


Sample Input 1

Copy
4 4

Sample Output 1

Copy
Yes
1
6
3
7
4
5
2

This case corresponds to the figure in the problem statement.


Sample Input 2

Copy
2 1

Sample Output 2

Copy
No

No matter what permutation was written into the blocks of step N, the integer written into the block of step 1 would be 2.

题意:给一个N层的金字塔,给出顶部的方块数字,其他未知,要求每一个方块都是其下方,下左方和下右方的中位数,输出最底层符合要求的情况,不行就输出No。

思路:当x=1或x=2*n-1时不可以,因为从第二层到第一层时肯定不会是它俩,对于首层为x,底层合法的情况化为01串,将两个1摆在中间,对于首层为x-1的01串,将两个0摆在中间,这样就一定是合法的情况,那么中间三个取值为x-1,x,x+1就行。

# include <stdio.h>
int main()
{
    int n, x, t=1;
    scanf("%d%d",&n,&x);
    if(x == 1 || x == 2*n-1)
        return 0*puts("No");
    puts("Yes");
    for(int i=1; i<n-1; ++i)
    {
        while(t==x || t==x-1 || t==x+1) ++t;
        printf("%d\n",t++);
    }
    printf("%d\n%d\n%d\n",x-1,x,x+1);
    for(int i=1; i<n-1; ++i)
    {
        while(t==x || t==x-1 || t==x+1) ++t;
        printf("%d\n",t++);
    }
    return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值