XTUOJ1264:Partial Sum(前缀和)

Partial Sum

Accepted : 4 Submit : 12
Time Limit : 3000 MS Memory Limit : 65536 KB 

Partial Sum

Bobo has a integer sequence  a1,a2,,an  of length  n . Each time, he selects two ends  0l<rn  and add  |rj=l+1aj|C  into a counter which is zero initially. He repeats the selection for at most  m  times.

If each end can be selected at most once (either as left or right), find out the maximum sum Bobo may have.

Input

The input contains zero or more test cases and is terminated by end-of-file. For each test case:

The first line contains three integers  n m C . The second line contains  n  integers  a1,a2,,an .

  • 2n105
  • 12mn+1
  • |ai|,C104
  • The sum of  n  does not exceed  106 .

Output

For each test cases, output an integer which denotes the maximum.

Sample Input

4 1 1
-1 2 2 -1
4 2 1
-1 2 2 -1
4 2 2
-1 2 2 -1
4 2 10
-1 2 2 -1

Sample Output

3
4
2
0

思路:先统计前缀和,由于和取绝对值,所以可以直接进行排序,又每个点只能选一次,首尾两个指针同时向中间靠即可,遇到<C的直接退出。

# include <iostream>
# include <cstdio>
# include <cstring>
# include <algorithm>
using namespace std;

const int N = 100030;
typedef long long LL;
LL a[N];
int main()
{
    LL n, m, c, t;
    while(~scanf("%I64d%I64d%I64d",&n,&m,&c))
    {
        a[0] = 0;
        for(LL i=1; i<=n; ++i)
        {
            scanf("%I64d",&t);
            a[i] = a[i-1] + t;
        }
        sort(a, a+1+n);
        LL sum=0, cnt=0;
        for(LL i=0,j=n; i<j&&cnt<m ; ++i,--j)
        {
            LL tmp = a[j]-a[i];
            if(tmp >= c)
                sum += tmp,++cnt;
            else
                break;
        }
        printf("%I64d\n",sum-cnt*c);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值