CFgym:Castle(KMP)

K. has stumbled upon a weird game while playing on his computer. The game consists of an initial
string S of length N (1 ≤ N ≤ 1000) and an empty set T. The following events might occur during
the game:
• a character is added at the end of S, thus increasing its length by 1
• the string S is added to the set T
• the game master inquires: “How many strings in T are suffixes of S?”. A suffix of S is a substring
which can start at any position in S, but must finish on the last position of S.
Because K. wants to go visit a famous castle near his hometown, you must help him deal with the
game as quickly as possible.
Input
The input file contains several test cases, each of them as described below.
The first line of the input contains two integers: N, the length of the initial string S and E, the
number of events (E ≤ 1200000).
The second line describes the string S; the string consists only of lowercase Roman alphabet (a..z).
The following E lines describe the events. Each of these lines contains an integer p, describing the
event type.
• If p is 1, then it is followed by a character (a-z), which will be added at the end of S.
• If p is 2, then the string S is added in T.
• If p is 3, then you must respond to the query “How many strings in T are suffixes of the current
S?”
Output
For each test case, the output must follow the description below.
The output should consist of a line containing an integer for each type 3 event in the input, which
represents the answer to the query. Note: T is a set, so it doesn’t contain duplicates.
Explanation for the sample:
Initially S is ‘a’.
After the first event T becomes {a}.
After the second and third event S becomes ‘aba’.
After the fourth event T becomes {a, aba}.
After the fifth event T becomes {a, aba}.
After the sixth and seventh event S becomes ‘abaca’.
The result of the query is 1 (‘a’).
After the ninth and tenth event S becomes ‘abacaba’.
The result of the query is 2 (‘a’ and ‘aba’).
Sample Input
1 11 

a

2

1 b
1 a 

2

2
1 c
1 a 

3
1 b
1 a 

3
Sample Output 

1

2

思路:根据KMP的next数组的特点即可。

//reference: WeAreATeam
# include <bits/stdc++.h>
using namespace std;
const int maxn = 1201003;
char s[maxn];
int Next[maxn];
bool vis[maxn];
int val[maxn];
int main()
{
    int n, q;
    scanf("%d%d",&n,&q);
    scanf("%s",s);
    for(int i=1; i<n; ++i)
    {
        int j=Next[i];
        while(j&&s[i]!=s[j]) j=Next[j];
        Next[i+1] = s[j]==s[i]?j+1:0;
    }
    while(q--)
    {
        int op;
        scanf("%d",&op);
        if(op == 1)
        {
            scanf("%s",s+n);
            int j=Next[n];
            while(j&&s[j]!=s[n]) j=Next[j];
            if(s[j]==s[n]) ++j;
            Next[++n] = j;
            val[n] = val[j];
        }
        else if(op == 2)
        {
            if(!vis[n])
            {
                vis[n] = 1;
                ++val[n];
            }
        }
        else
            printf("%d\n",val[n]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值