Partitioning by Palindromes(回文串-->字符串DP)

Partitioning by Palindromes

Can you read upside-down?

We say a sequence of characters is a palindrome if it is the same written forwards and backwards. For example, 'racecar' is a palindrome, but 'fastcar' is not.

partition of a sequence of characters is a list of one or more disjoint non-empty groups of consecutive characters whose concatenation yields the initial sequence. For example, ('race', 'car') is a partition of 'racecar' into two groups.

Given a sequence of characters, we can always create a partition of these characters such that each group in the partition is a palindrome! Given this observation it is natural to ask: what is the minimum number of groups needed for a given string such that every group is a palindrome?

For example:

  • 'racecar' is already a palindrome, therefore it can be partitioned into one group.
  • 'fastcar' does not contain any non-trivial palindromes, so it must be partitioned as ('f', 'a', 's', 't', 'c', 'a', 'r').
  • 'aaadbccb' can be partitioned as ('aaa', 'd', 'bccb').

Input begins with the number n of test cases. Each test case consists of a single line of between 1 and 1000 lowercase letters, with no whitespace within.

For each test case, output a line containing the minimum number of groups required to partition the input into groups of palindromes.

Sample Input

3
racecar
fastcar
aaadbccb

Sample Output

1
7
3
[Description]
回文串就是正着读和反着读都是一样的,比如  'racecar'  就是一个回文串,而  'fastcar'  不是。
你可以把一个字符串分成若干个非空子串,例如  ‘racecar’  可以分为  ‘race’  和  ‘car’  两个子
串。
给你一个字符串,你需要把他分成若干个子串,并且每一个子串都要是文回传,那么我们最
少需要分成多少个子串?
[Input]
第一行一个整数 T,表示 T 组数据。
对于每组数据,一行一个非空字符串,只包含不超过 1000 个的小写字母。
[Output]
对于每组数据输出一行,即最少要分的组数
[Sample Input]
3
racecar
fastcar
aaadbccb
[Sample Output]
1
7
3
[Hint]
对于第二个样例:
把原串分成  'f', 'a', 's', 't', 'c', 'a', 'r'  七个子串,才能使每个都为回文串
对于第三个样例:
把原串分成  'aaa', 'd', 'bccb'  三个子串
 
/*没什么说的
 
#include<iostream>
#include<cstdio>
#include<cstring>
#define inf 0x3f3f3f3f
using namespace std;
char str[1010];
int dp[1010];

bool check(char s[],int l,int r)
{
    for(int i=l,j=r;i<=r;i++,j--)
        if(s[i]!=s[j])return false;
    return true;
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s",str+1);
        int len=strlen(str+1);
		for(int i=0;i<=len;i++)dp[i]=inf;
        dp[0]=0;
        for(int i=1;i<=len;i++)
        {
            for(int j=1;j<=len;j++)
            {
                if(check(str,j,i))
                    dp[i]=min(dp[i],dp[j-1]+1);
            }
        }
        printf("%d\n",dp[len]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值