Strategic game

Strategic game

Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?

Your program should find the minimum number of soldiers that Bob has to put for a given tree.

For example for the tree:

the solution is one soldier (at the node 1).

Input 

The input file contains several data sets in text format. Each data set represents a tree with the following description:
  • the number of nodes
  • the description of each node in the following format:
    node_identifier:(number_of_roads) node_identifier1 node_identifier2 � node_identifiernumber_of_roads
    or
    node_identifier:(0)
The node identifiers are integer numbers between 0 and n-1, for n nodes ( 0 < n ≤ 1500). Every edge appears only once in the input data.

Output 

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers).

Sample Input 

4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)

Sample Output 

1
2
译:
[Description]
Bob 特别喜欢战略游戏,但有时他不能尽快找到最优解, 所以他就很伤心。现在他又有一个
问题,他必须保卫一个中世纪的城市,这个城市的道路形成了一棵树。他需要在树的节点上
放最少的士兵来观察所有的边。你能帮助他么?
例如右图就只需要一个士兵放在 1 号节点。
[Input]
多组数据直到 EOF
对于每组数据第一行 N 表示点的个数。接下来 N 行每行如下
x:(k) a1 a2 … ak
(x 为点的编号,k 为与其相连的子节点个数,a1, a2, …, ak 分别为子节点的编号)
[Output]
对于每组数据输出一行一个数,即最少士兵数
[Sample Input]
4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)
[Sample Output]
1
2
[Hint]
0 < N <= 1500, 0 <= x < N

/*树形DP
CASE1:父亲结点放置了,儿子结点可以放置也可以不放置
CASE2:父亲结点没有放置,儿子结点必须放置
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
/*
	树形DP 
*/
const int MAXN=1510;
struct Node
{
    int father,brother,child;
    int yes;//该结点放置
    int no;//该结点不放置
}t[MAXN];
void DFS(int x)
{
    int child=t[x].child;
    while(child)
    {
        DFS(child);
        t[x].yes+=min(t[child].yes,t[child].no);
        //父亲结点放置了,儿子结点可以放置也可以不放置
        t[x].no+=t[child].yes;
        //父亲结点没有放置,儿子结点必须放置
        child=t[child].brother;
    }
}
bool used[MAXN];
int main()
{
    int n;
    int root,k,v;
    while(scanf("%d",&n)!=EOF)
    {
        memset(used,false,sizeof(used));
        int Root;//根结点
        for(int i=0;i<n;i++)
        {
            scanf("%d:(%d)",&root,&k);
            root++;//编号从1开始
            if(i==0)Root=root;
            if(!used[root])
            {
                used[root]=true;
                t[root].brother=t[root].father=t[root].child=0;
                t[root].yes=1;
                t[root].no=0;
            }
            while(k--)
            {
                scanf("%d",&v);
                v++;
                if(!used[v])
                {
                    used[v]=true;
                    t[v].brother=t[v].father=t[v].child=0;
                    t[v].yes=1;
                    t[v].no=0;
                }
                t[v].brother=t[root].child;
                t[v].father=root;
                t[root].child=v;
            }

        }
        DFS(Root);
        printf("%d\n",min(t[Root].yes,t[Root].no));

    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值