最简单的加法运算1001,1002

acm.hit.edu.cn

1001

A+B


for each pair of integers A and B ( 0 <= A,B <= 10) , Output the result of A+B on a single line. Sample Input

1 2
3 4
Sample Output
3
7
Sample Code
#include <stdio.h>
int main(void)
{
    int a, b;
    while (scanf("%d %d", &a, &b)==2)
        printf("%d\n",a+b);
    return 0;
}
 
 

#include<stdio.h>
#include<math.h>
#include<iostream>
using namespace std;
int main()
{
        int a,b;
        while(scanf("%d%d",&a,&b) == 2)
        {
                printf("%d\n",a+b);
        }
        return 0;
}


1002

A+B+C


For each pair of integers A B and C ( -2^31 <= A, B, C<= 2^31-1 ), Output the result of A+B+C on a single line. Sample Input

1 2 3
3 4 3
Sample Output
6
10
提示 请注意32位机上int的表示范围。


#include<stdio.h>
#include<math.h>
#include<iostream>
using namespace std;
int main()
{
 long long int a, b, c;
 while(scanf("%lld %lld %lld",&a,&b,&c) == 3)
 {
  printf("%lld\n",a+b+c);
 }
 return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值