暑假非集训队练习赛第六场——A - Encoding

Description

Given a string containing only 'A' - 'Z', we could encode it using the following method: 

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string. 

2. If the length of the sub-string is 1, '1' should be ignored. 

 

Input

The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000. 

 

Output

For each test case, output the encoded string in a line. 

 

Sample Input

 

2 ABC ABBCCC

 

Sample Output

 

ABC A2B3C

 

 

 

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cstdlib>
#include <cstring>
const int maxn = 10001;
using namespace std;
int main()
{
    int n;
    scanf("%d",&n);
    getchar();
    while(n--)
    {
        char x;
        int m,i,j,k=1;
        int b[26];
        memset(b,0,sizeof(b));
        char a[maxn];

        gets(a);
        m=strlen(a);
        for(i=0; i<m; i++)
        {
            x=a[i];
            for(j=i+1; j<m; j++)
            {
                if(a[j]==a[i])
                {
                    k++;

                }
                else
                    break;

            }
            i+=k-1;


            if(k==1)
            {
                printf("%c",x);
                k=1;
            }
            if(k>1)
            {
                printf("%d",k);
                printf("%c",x);
                k=1;
            }

        }
        /*for(i=0; i<26; i++)
         {
             if(b[i]==0)
                 continue;
             else if(b[i]==1)
                 printf("%c",i+65);
             else
             {
                 printf("%d",b[i]);
                 printf("%c",i+65);
             }
         }*/
        printf("\n");
    }
    return 0;
}
 

 

在输入ASSDS时输出应该是A2SDS而不是A3SD,程序要求你对连续的相同的字符进行计数,而不是对全部的进行计数。刚开始我开了两个数组,一个用来存储字符串,另一个开了26个,用来记数,但是这种方法只能用来对于串中不连续出现的也一起计数。后来经过改进。得出以上代码,

但是我的这种方法最要注意的是,先找一样的,然后++,但是循环时要把一样的给跳过去,于是就有了k+=i;

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值