暑假非集训队练习赛第七场——A - Number Sequence(kmp)

Description

Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one. 

 

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000]. 

 

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead. 

 

Sample Input

 

2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1

 

Sample Output

 

6 -1

 

 

#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cstdio>
int p[1000010];
int q[1000010];
int nextt[1000010];
using namespace std;
void nnext(int *s2,int *nextt,int b)
{
    nextt[0]=-1;
    int k=-1;
    int j=0;
    while(j<b)
    {
        if(k==-1||s2[j]==s2[k])
        {
            k++;
            j++;
            nextt[j] = k;
        }
        else
            k=nextt[k];
    }
}
int kmp(int *s1,int *s2,int *nextt,int a,int b)
{
    int i=0;
    int j=0;
    while(i<a&&j<b)
    {
        if(s1[i]==s2[j]||j==-1)
        {
            i++;
            j++;
        }
        else
            j=nextt[j];
    }
    if(j==b)
        return i-j+1;
    else
        return -1;

}
int main()
{
   int n;
   scanf("%d",&n);
   while(n--)
   {
       int a,b,i;
       scanf("%d %d",&a,&b);
       for(i=0;i<a;i++)
       {
           scanf("%d",&p[i]);
       }
       for(i=0;i<b;i++)
       {
           scanf("%d",&q[i]);
       }
       nnext(q,nextt,b);
       printf("%d\n",kmp(p,q,nextt,a,b));


   }
   return 0;
}
 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值