POJ-2386 Lake Counting

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John's field, determine how many ponds he has.
Input
* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.
Output
* Line 1: The number of ponds in Farmer John's field.
Sample Input
10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.
Sample Output
3
Hint
OUTPUT DETAILS:

There are three ponds: one in the upper left, one in the lower left,and one along the right side.

问题:w视为水,在一个水作为中心的九宫格只要有W则认为这两个是相连的水洼...问有多少个水洼;

分析:深搜的练手...从随便一个W开始不停寻找它附近联通的w然后改成‘.’就行了...最后调用DFS的次数就是水洼数;

#include<cstdio>
#define Max_N 10010
#define Max_M 10010
int N,M;
char field[Max_N][Max_M+1];

void input(){
	
	for(int i=0;i<N;i++){
		for(int j=0;j<M;j++){
			scanf("%c",&field[i][j]);	
		}
		getchar();//这个要注意啊...是为了接受呢个\0?
	}
}
void dfs(int x,int y){
	//把当前点从W改成. 
	field[x][y]='.';
	
	for(int dx=-1;dx<=1;dx++){
		for(int dy=-1;dy<=1;dy++){
			//向各个方向移动 
			int nx=x+dx,ny=y+dy;
			//判断条件,看是否在范围内 
			if(0<=nx&&nx<N&&0<=ny&&ny<M&&field[nx][ny]=='W') dfs(nx,ny);
		}
	}
}

void solve(){
	int res=0;
	for(int i=0;i<N;i++){
		for(int j=0;j<M;j++){
			if(field[i][j]=='W'){
				dfs(i,j);
				res++;
			}
		}
	} 
	printf("%d\n",res);
}

int main(){
	while(scanf("%d %d",&N,&M)!=EOF){
		getchar();
		input();
		solve();
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值