poj2386——Lake Counting(搜索)

Description

Due to recent rains, water has pooled in various places in Farmer John’s field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water (‘W’) or dry land (‘.’). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John’s field, determine how many ponds he has.
Input

  • Line 1: Two space-separated integers: N and M

  • Lines 2..N+1: M characters per line representing one row of Farmer John’s field. Each character is either ‘W’ or ‘.’. The characters do not have spaces between them.
    Output

  • Line 1: The number of ponds in Farmer John’s field.
    Sample Input

10 12
W……..WW.
.WWW…..WWW
….WW…WW.
………WW.
………W..
..W……W..
.W.W…..WW.
W.W.W…..W.
.W.W……W.
..W…….W.
Sample Output

3

相邻的W组成一个池塘,统计池塘的个数,很水的搜索

#include <iostream>
#include <algorithm>
#include <cstring>
#include <string>
#include <cmath>
#include <cstdio>
#include <set>
#include <vector>
#include <iomanip>
#include <stack>
#include <map>
#define MAXN 105
#define mod 9973
#define inf 0x3f3f3f3f
using namespace std;
int vis[MAXN][MAXN],n,m;
char a[MAXN][MAXN];
void fun(int x,int y)
{
    if(x<0||x>n||y<0||y>m||a[x][y]=='.'||vis[x][y])
        return;
    vis[x][y]=1;
    fun(x+1,y);
    fun(x-1,y);
    fun(x,y+1);
    fun(x,y-1);
    fun(x+1,y-1);
    fun(x+1,y+1);
    fun(x-1,y+1);
    fun(x-1,y-1);
}
int main()
{
    ios::sync_with_stdio(false);
    while(cin>>n>>m)
    {
        memset(a,'.',sizeof(a));
        for(int i=0; i<n; ++i)
            for(int j=0; j<m; ++j)
                cin>>a[i][j];
        memset(vis,0,sizeof(vis));
        int ans=0;
        for(int i=0; i<n; ++i)
            for(int j=0; j<m; ++j)
            {
                if(!vis[i][j]&&a[i][j]=='W')
                {
                    fun(i,j);
                    ans++;
                }
            }
        cout<<ans<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值