HDU-2054 A==B?

Problem Description
Give you two numbers A and B, if A is equal to B, you should print "YES", or print "NO".
 

Input
each test case contains two numbers A and B.
 

Output
for each case, if A is equal to B, you should print "YES", or print "NO".
 

Sample Input
  
  
1 2 2 2 3 3 4 3
 

Sample Output
  
  
NO YES YES NO 这么水的题居然错了好几次...主要几个点1.这个数有可能有小数点2.也是为什么我没AC...字符数组开小了...题目里没给大小我开了10000最后改成100000就AC了...
#include<cstdio>
#include<cstring>

char a1[100000],b[100000];
void quchu(char a[]){//去除末尾0的影响
	int len,i;
	len=strlen(a);
	if(strstr(a,".")){
		for(i=len-1;a[i]=='0';i--){
			a[i]='\0';
			len--;
		}
	}
	if(a[len-1]=='.')
		a[len-1]='\0';
}
int main(){
	
	while(scanf("%s%s",a1,b)!=EOF){
		quchu(a1);
		quchu(b);
		if(strcmp(a1,b)) printf("NO\n");
		else printf("YES\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值