Leftmost Digit (HDU 1060)

  这题我是看到别人说的公式才会做的,公式相关的式子n^n=10^(n*(lgn)),n^n=(10^m)*(10^k),m为整数,k为小数,而n^n最左边的数取决于小数。。

具体公式见代码,,虽然其实我也不是特别懂= =

                        Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12445    Accepted Submission(s): 4743


Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.


 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).


 

Output
For each test case, you should output the leftmost digit of N^N.


 

Sample Input
  
  
2 3 4


 

Sample Output
  
  
2 2
Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2. In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.

代码如下:

#include<stdio.h>
#include<math.h>
int main()
{
    int p,t;
    double k,n;

    scanf("%d",&t);
    while(t--)
    {
        scanf("%lf",&n);
        k=n*(log(n)/log(10))-floor(n*(log(n)/log(10)));
        k=pow(10.0,k);
        p=k;
        printf("%d\n",p);
    }
    return 0;
}


顺便说一下,这代码在杭电上已过,但输入2的时候应该输出4,而编译输出的是3,不知为什么,,求大神指教

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值