Nightmare (HDU 1072)—— BFS

Nightmare

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7258    Accepted Submission(s): 3482


Problem Description
Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius' start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:
1. We can assume the labyrinth is a 2 array.
2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
3. If Ignatius get to the exit when the exploding time turns to 0, he can't get out of the labyrinth.
4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can't use the equipment to reset the bomb.
5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
There are five integers which indicate the different type of area in the labyrinth:
0: The area is a wall, Ignatius should not walk on it.
1: The area contains nothing, Ignatius can walk on it.
2: Ignatius' start position, Ignatius starts his escape from this position.
3: The exit of the labyrinth, Ignatius' target position.
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.

Output
For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.

Sample Input
  
  
3 3 3 2 1 1 1 1 0 1 1 3 4 8 2 1 1 0 1 1 1 0 1 0 4 1 1 0 4 1 1 0 0 0 0 0 0 1 1 1 1 4 1 1 1 3 5 8 1 2 1 1 1 1 1 4 1 0 0 0 1 0 0 1 1 4 1 0 1 1 0 1 1 0 0 0 0 3 0 1 1 1 4 1 1 1 1 1

Sample Output
  
  
4 -1 13

题意:给你n*m的矩阵,一个人在2处,有一个炸弹还有6秒爆炸,故他需在爆炸前逃到3处。0处不能走,1处随便走,4处可以将炸弹爆炸时间重置为6秒(移动一格花费1秒)。如果能到3处输出总共花费多长时间,否则输出-1.

 

分析:利用BFS解决。此题最重要的一点是判断已走过的路是否需要再次走,所以中间的判断条件t[x][y]>t[nx][ny] 非常关键,如果已走过的点的前面那个点比已走过的点的所剩爆炸时间长,则可入队。而且也避免许多点往回走浪费时间,并且4那个点也只需走一遍

#include<cstdio>
#include<queue>
using namespace std;
int n, m, a[10][10], time[10][10]; //time表示总共花费时间
int dx[] = {0,0,-1,1}, dy[] = {-1,1,0,0};

int bfs(int x,int y)
{
   int u, nx, ny, t[10][10] = {0}; //t代表所剩爆炸时间
   t[x][y] = 6; time[x][y] = 0;
   queue<int> q;
   q.push(x*m+y);
   while(!q.empty())
   {
       u = q.front(); q.pop();
       x = u/m; y = u%m;
       if(a[x][y] == 3) return time[x][y];
       if(t[x][y] <= 1) continue; //当爆炸时间最多还剩1秒并且依然没到终点时不需再搜
       for(int d=0; d<4; d++)
       {
           nx = x+dx[d]; ny = y+dy[d];
           if(nx>=0 && nx<n && ny>=0 && ny<m && a[nx][ny] && t[x][y]>t[nx][ny]/*此处为重点*/)
           {
              q.push(nx*m+ny);
              time[nx][ny] = time[x][y]+1;
              if(a[nx][ny] == 4) a[nx][ny] = 0, t[nx][ny] = 6; //重置爆炸时间,并且只需一次
              else t[nx][ny] = t[x][y]-1;
           }
       }
   }
   return -1;
}

int main()
{
    int T, i, j, x, y;

    while(~scanf("%d", &T))
    {
        while(T--)
        {
            scanf("%d%d", &n,&m);
            for(i=0; i<n; i++)
                for(j=0; j<m; j++)
                {
                    scanf("%d", &a[i][j]);
                    if(a[i][j] == 2) x = i, y = j;
                }
            printf("%d\n", bfs(x,y));
       }
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值