Help him (BestCoder Round #12) HDU 5059

Help him


Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1829 Accepted Submission(s): 137


Problem Description
  
  
As you know, when you want to hack someone's program, you must submit your test data. However sometimes you will submit invalid data, so we need a data checker to check your data. Now small W has prepared a problem for BC, but he is too busy to write the data checker. Please help him to write a data check which judges whether the input is an integer ranged from a to b (inclusive). Note: a string represents a valid integer when it follows below rules. 1. When it represents a non-negative integer, it contains only digits without leading zeros. 2. When it represents a negative integer, it contains exact one negative sign ('-') followed by digits without leading zeros and there are no characters before '-'. 3. Otherwise it is not a valid integer.
Input
  
  
Multi test cases (about 100), every case occupies two lines, the first line contain a string which represents the input string, then second line contains a and b separated by space. Process to the end of file. Length of string is no more than 100. The string may contain any characters other than '\n','\r'. -1000000000 ab1000000000
Output
  
  
For each case output "YES" (without quote) when the string is an integer ranged from a to b, otherwise output "NO" (without quote).
Sample Input
  
  
10 -100 100 1a0 -100 100
Sample Output
  
  
YES NO


题意:

判断给你的字符串转换成数字时是否合法,并且数字大小要在[a,b]范围内。


分析:

一开始写了一大堆,判断各种不合法的情况,而且可能还有转义字符,所以写到最后还是WA。。。后来发现其实有一种非常简单的想法:只需把字符串先转换成数字,用itoa函数或者sprintf函数转换,由于如果出现不合法的字符出现时转换就会停止(例如:-10a54,中间的a是不合法的,所以这个字符串在被转换成数字时会是-10. ),然后再把这个数字转换成字符串,最后比较这个字符串和它所给的字符串是否相等,并且在[a,b]范围内,如果是的话就输出YES,否则输出NO。


结论:想法很重要!!!

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
int main()
{
    int a, b;
    char m[110], c[110];

    while(gets(m))
    {
        scanf("%d%d", &a,&b);
        getchar();
        int x = atoi(m);
        sprintf(c, "%d", x);
        //itoa(x,c,10);
        if(strcmp(m,c) == 0 && x >=a && x <= b) puts("YES");
        else puts("NO");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值