joj 1004: Octal Fractions

ResultTIME LimitMEMORY LimitRun TimesAC TimesJUDGE
3s8192K3686828Standard

Fractions in octal (base 8) notation can be expressed exactly in decimal notation. For example, 0.75 in octal is 0.963125 (7/8 + 5/64) in decimal. All octal numbers of n digits to the right of the octal point can be expressed in no more than 3n decimal digits to the right of the decimal point. Write a program to convert octal numerals between 0 and 1, inclusive, into equivalent decimal numerals. The input to your program will consist of octal numbers, one per line, to be converted. Each input number has the form 0.d1d2d3 ... dk, where the di are octal digits (0..7). There is no limit on k. Your output will consist of a sequence of lines of the form

0.d1d2d3 ... dk [8] = 0.D1D2D3 ... Dm [10]

where the left side is the input (in octal), and the right hand side the decimal (base 10) equivalent. There must be no trailing zeros, i.e. Dm is not equal to 0.

SAMPLE INPUT

0.75
0.0001
0.01234567

SAMPLE OUTPUT

0.75 [8] = 0.953125 [10]
0.0001 [8] = 0.000244140625 [10]
0.01234567 [8] = 0.020408093929290771484375 [10]

/*

孔牛用的秦九韶算法,我这里贴的算法是利用千进制数作为中间媒介来达到八进制与十进制之间的转换,时间上一样,其实算法的本质也是一样(早期的代码,比较乱);

*/

#include <iostream>
#include <stdio.h>
#include <memory>
#include <string.h>
using namespace std;
const int maxn=2000;
double oct[8]={0,125,250,375,500,625,750,875};
int main ()
{
 char str[maxn];
 int oc[maxn],dec[3*maxn];
 while (memset(str,'/0',sizeof(str)),cin>>str)
 {
  int i,len=strlen(str),j;
  for( i=0 ,j=len-1;str[j]!='.' ; i++,j--)
   oc[i]=str[j]-48;
   cout<<str<<" [8] = 0.";
  for( i=0 ;i<len-2 ; i++)
   for( j=0 ; j<len-2-i ; j++)
    {
     oc[j]=oc[j]*125;
     if( oc[j]>999)
     {
      oc[j+1]+=oc[j]/1000;
      oc[j]=oc[j]%1000;
     }
    }//千进制 (将原数×125存到新的数组里)
  for(i=len-3 ; i>0 ;i--)
  {
   if(oc[i]>99)
   cout<<oc[i];
   else if(oc[i]<100 && oc[i]>9)
   cout<<"0"<<oc[i];
   else if(oc[i]<10)
   cout<<"00"<<oc[i];
  }// 3位一输出,不够的加前导零;
 
  if (oc[0]%10)cout<<oc[0];
  else if(oc[0]%100)cout<<oc[0]/10;
  else if(!(oc[0]%100))cout<<oc[0]/100;
  //清后缀零
  cout<<" [10]/n" ;
 }
 return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值