POJ-2251 Dungeon Master

                         Dungeon Master
          Time Limit: 1000MS        Memory Limit: 65536K
          Total Submissions: 26734      Accepted: 10442

Description

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.

Is an escape possible? If yes, how long will it take?
Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).
L is the number of levels making up the dungeon.
R and C are the number of rows and columns making up the plan of each level.
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a ‘#’ and empty cells are represented by a ‘.’. Your starting position is indicated by ‘S’ and the exit by the letter ‘E’. There’s a single blank line after each level. Input is terminated by three zeroes for L, R and C.
Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form
Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape.
If it is not possible to escape, print the line
Trapped!
Sample Input
3 4 5
S . . . .
. ###.
. ##. .
###.#

#####
#####
##. ##
## . . .

#####
#####
#. ###
####E

1 3 3
S##
#E#
###

0 0 0

Sample Output
Escaped in 11 minute(s).
Trapped!
题解:简单的三维bfs,不多说,直接看代码。

#include<iostream>
#include<queue>
#include<string.h>
using namespace std;
char Dungeon[31][31][31];
bool Judge[31][31][31];    //判断该点是否走过   
int dir[6][3] = { {0,-1,0},{0,0,-1},{0,1,0},{0,0,1},{-1,0,0},{1,0,0} };     //6个方向
int L, R, C, sl, sr, sc;
struct Node {
    int l, r, c, t;
};
queue<Node>Q;
bool func(int z, int x, int y)
{
    if (z >= 0 && z < L&&x >= 0 && x < R&&y >= 0 && y < C)
        return true;
    return false;
}
int bfs()
{
    memset(Judge, false, sizeof(Judge));
    Node q, f;
    q.l = sl; q.r = sr; q.c = sc; q.t = 0;
    Q.push(q);
    Judge[sl][sr][sc] = true;
    while (!Q.empty())
    {
        q = Q.front();
        Q.pop();
        if (Dungeon[q.l][q.r][q.c] == 'E')
            return q.t;
        for (int i = 0; i < 6; i++)
        {
            f.l = q.l + dir[i][0];
            f.r = q.r + dir[i][1];
            f.c = q.c + dir[i][2];
            f.t = q.t + 1;
            if (func(f.l, f.r, f.c) && !Judge[f.l][f.r][f.c] && Dungeon[f.l][f.r][f.c]!= '#')
            {
                Q.push(f);
                Judge[f.l][f.r][f.c] = true;
            }
        }
    }
    return -1;
}
int main()
{
    while (scanf("%d%d%d", &L, &R, &C) && (L || R || C))
    {
        while (!Q.empty())
            Q.pop();       //清空队列
        int key = 0;
        for (int i = 0; i < L; i++)
        {
            getchar();
            for (int j = 0; j < R; j++)
            { 
                gets(Dungeon[i][j]);
                int len=strlen(Dungeon[i][j]);
                for (int k = 0; k < len&&!key; k++)
                    if (Dungeon[i][j][k] == 'S')
                    {
                        sl = i; sr = j; sc = k; 
                        key = 1;
                    }
            }
        }
        int time = bfs();
        if (time != -1)
            printf("Escaped in %d minute(s).\n", time);
        else
            printf("Trapped!\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值