poj 3041 Asteroids 匈牙利算法

Asteroids
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11247 Accepted: 6100

Description

Bessie wants to navigate her spaceship through adangerous asteroid field in the shape of an N x N grid (1<= N <= 500). The grid contains Kasteroids (1 <= K <= 10,000), whichare conveniently located at the lattice points of thegrid. 

Fortunately, Bessie has a powerful weapon that can vaporize all theasteroids in any given row or column of the grid with a singleshot.This weapon is quite expensive, so she wishes to use itsparingly.Given the location of all the asteroids in the field,find the minimum number of shots Bessie needs to fire to eliminateall of the asteroids.

Input

* Line 1: Two integers N and K, separated by asingle space. 
* Lines 2..K+1: Each line contains two space-separated integers Rand C (1 <= R, C <= N) denoting therow and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimumnumber of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS: 
The following diagram represents the data, where "X" is an asteroidand "." is empty space: 
X.X 
.X. 
.X.
 

OUTPUT DETAILS: 
Bessie may fire across row 1 to destroy the asteroids at (1,1) and(1,3), and then she may fire down column 2 to destroy the asteroidsat (2,2) and (3,2).

Source


题目大意:矩阵上有一些小行星,占据了一些格子,我们每次操作可以清理一列中的所有小行星,也可以清理一行中的所有小行星,问最少进行多少次操作可以清理掉所有的小行星。
匈牙利算法
#include <iostream>
#include <cstring>
using namespace std;

int n,k;
int v1,v2;
bool grid[501][501];
bool vis[501];
int link[501];
int m;

bool dfs (int x)
{
    for(int y=1;y<=v2;y++)
        if(grid[x][y]&&!vis[y])
    {
        vis[y]=true;
        if(link[y]==0||dfs(link[y]))
        {
            link[y]=x;
            return true;
        }
    }
    return false;
}

void search()
{
    for(int x=1;x<=v1;x++)
    {
        memset (vis,false,sizeof(vis));
        if(dfs(x))
            m++;
    }
    return ;
}

int main()
{
    cin>>n>>k;
    v1=v2=n;
    int x,y;
    for(int i=1;i<=k;i++)
    {
        cin>>x>>y;
        grid[x][y]=true;
    }
    search();
    cout<<m<<endl;
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值