poj 3264 Balanced Lineup 线段树+RMQ_ST算法 一题多解

Balanced Lineup
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 28687 Accepted: 13500
Case Time Limit: 2000MS

Description

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers,  N and  Q
Lines 2.. N+1: Line  i+1 contains a single integer that is the height of cow  i 
Lines  N+2.. N+ Q+1: Two integers  A and  B (1 ≤  A ≤  B ≤  N), representing the range of cows from  A to  B inclusive.

Output

Lines 1.. Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

Source

题意:
给出一列共n个数,m次询问。每次询问包括两个数a,b。输出区间[a,b]中最大值与最小值的差。
线段树:
#include<stdio.h>
#include<algorithm>
#include<iostream>
using namespace std;
#define MAXN 200005
#define INF 10000000
int maxx,minn;//记录最大最小值
struct Node
{
    int l,r;//区间的左右端点
    int minn,maxx;//区间的最小值和最大值
}tree[MAXN*3];
int a[MAXN];
void Build(int i,int l,int r)//在结点i上建立区间为(l,r)
{
    tree[i].l=l;
    tree[i].r=r;
    if(l==r)//叶子结点
    {
        tree[i].minn=tree[i].maxx=a[l];
        return;
    }
    int mid=(l+r)>>1;
    Build(i<<1,l,mid);
    Build(i<<1|1,mid+1,r);
    tree[i].minn=min(tree[i<<1].minn,tree[i<<1|1].minn);
    tree[i].maxx=max(tree[i<<1].maxx,tree[i<<1|1].maxx);
}
void Query(int i,int l,int r)//查询结点i上l-r的最大值和最小值
{
    if(tree[i].maxx<=maxx&&tree[i].minn>=minn)  return;
    if(tree[i].l==l&&tree[i].r==r)
    {
        maxx=max(tree[i].maxx,maxx);
        minn=min(tree[i].minn,minn);
        return;
    }
    int mid=(tree[i].l+tree[i].r)>>1;
    if(r<=mid)   Query(i<<1,l,r);
    else if(l>mid)  Query(i<<1|1,l,r);
    else
    {
        Query(i<<1,l,mid);
        Query(i<<1|1,mid+1,r);
    }
}
int main()
{
    int n,q;
    int l,r;
    int i;
    while(scanf("%d%d",&n,&q)!=EOF)
    {
        for(i=1;i<=n;i++)
          scanf("%d",&a[i]);
        Build(1,1,n);
        for(i=1;i<=q;i++)
        {
            scanf("%d%d",&l,&r);
            maxx=-INF;minn=INF;
            Query(1,l,r);
            printf("%d\n",maxx-minn);
        }
    }
    return 0;
}

ST算法:
假设要查询从m到n这一段的最小值, 那么我们先求出一个最大的k, 使得k满足2^k <(n - m + 1). 于是我们就可以把[m, n]分成两个(部分重叠的)长度为2^k的区间: [m, m+2^k-1], [n-2^k+1, n]; 而我们之前已经求出了f(m, k)为[m, m+2^k-1]的最小值, f(n-2^k+1, k)为[n-2^k+1, n]的最小值 我们只要返回其中更小的那个, 就是我们想要的答案, 这个算法的时间复杂度是O(1)的. 

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;
const int nMax= 50003;
int num[nMax],n;
int maxMap[nMax][20];
int minMap[nMax][20];
void maxRmq()         //map(i, j)表示[i, i+2^j - 1]区间中的最值
int i,j;
for(i=1; i<=n; i++)
{
    maxMap[i][0]=num[i];
}
for(j=1; j<=log((double)(n+1))/log(2.0); j++)
{
    for(i=1; i+(1<<j)-1<=n; i++)
    {
        maxMap[i][j]=max(maxMap[i][j-1],maxMap[i+(1<<(j-1))][j-1]);
    }
}
}  void minRmq()
{
    int i,j;
    for(i=1; i<=n; i++)
    {
        minMap[i][0]=num[i];
    }
    for(j=1; j<=log((double)(n+1))/log(2.0); j++)
    {
        for(i=1; i+(1<<j)-1<=n; i++)
        {
            minMap[i][j]=min(minMap[i][j-1],minMap[i+(1<<(j-1))][j-1]);
        }
    }
}
int askMax(int a,int b)
{
    if(a>b)swap(a,b);
    int k =(int)(log((double)(b-a+1))/log(2.0));
    return max(maxMap[a][k],maxMap[b-(1<<k)+1][k]);
}
int askMin(int a,int b)
{
    if(a>b)swap(a,b);
    int k=(int)(log((double)(b-a+1))/log(2.0));
    return min(minMap[a][k],minMap[b-(1<<k)+1][k]);
}
int main()
{
    int m,i,j,a,b;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        for(i=1; i<=n; i++)scanf("%d",&num[i]);
        maxRmq();
        minRmq();
        while(m--)
        {
            scanf("%d%d",&a,&b);
            printf("%d\n",askMax(a,b)-askMin(a,b));
        }
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值