poj_3264 Balanced Lineup 线段树+点修改/RMQ

Balanced Lineup
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 35257 Accepted: 16586
Case Time Limit: 2000MS

Description

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q.
Lines 2.. N+1: Line i+1 contains a single integer that is the height of cow i
Lines N+2.. N+ Q+1: Two integers A and B (1 ≤ ABN), representing the range of cows from A to B inclusive.

Output

Lines 1.. Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

线段树写法:

运行结果:

#include<stdio.h>
#include<cstdio>
#include <cstring>
#include<iostream>
#include<algorithm>
#define inf -0x3f3f3f3f
#define INF 0x3f3f3f3f
#define mem0(a) memset(a,0,sizeof(a))
using namespace std;
const int  num = 50000+10;
int _max[num<<2],_min[num<<2];
void GetMax(int cur){
    _max[cur] = max(_max[cur<<1],_max[cur<<1|1]);
}
void GetMin(int cur){
    _min[cur] = min(_min[cur<<1],_min[cur<<1|1]);
}
void build(int l,int r,int cur){
    if( l == r ){
        scanf("%d",&_max[cur]);
        _min[cur] = _max[cur];
        return ;
    }
    int mid= (l + r )>>1;
    build(l,mid,cur<<1);
    build(mid+1,r,cur<<1|1);
    GetMax(cur);
    GetMin(cur);
}

int  query1(int ql,int qr,int l,int r,int cur){
    int mid = ( l + r )>>1 ;
    int ma =  inf;
    if(ql <= l && qr >= r)  return _max[cur];
    if(ql <= mid) ma = max( ma , query1(ql,qr,l,mid,cur<<1));
    if(qr > mid ) ma = max( ma , query1(ql,qr,mid+1,r,cur<<1|1));
    return ma ;
}
int  query2(int ql,int qr,int l,int r,int cur){
    int mid = ( l + r )>>1 ;
    int mi = INF;
    if(ql <= l && qr >= r)  return _min[cur];
    if(ql <= mid) mi = min(mi , query2(ql,qr,l,mid,cur<<1));
    if(qr > mid ) mi = min(mi , query2(ql,qr,mid+1,r,cur<<1|1));
    return mi ;
}
int main()
{
    int N,M;
    while(scanf("%d%d",&N,&M)!=EOF){
        build(1,N,1);
        while(M--){
            int a,b;
            scanf("%d%d",&a,&b);
            printf("%d\n",query1(a,b,1,N,1)-query2(a,b,1,N,1));
        }
    }
    return 0;
}


RMQ方法解:

有关RMQ算法讲解可以参考:RMQ (Range Minimum/Maximum Query)算法

运行结果:

 RMQ算法运行时间要比线段树少点,在南阳理工士兵杀敌3中,RMQ可以过,线段树就超时。。因此遇到类似问题建议用RMQ算法

#include<cstdio>
#include<algorithm>
#include<cmath>
using namespace std;

const int N = 50010;//2^20=1048576>50010
int maxsum[N][20], minsum[N][20];

void RMQ(int num) //预处理->O(nlogn)
{
	for(int j = 1; j < 20; ++j)
		for(int i = 1; i <= num; ++i)
			if(i + (1 << j) - 1 <= num)
			{
				maxsum[i][j] = max(maxsum[i][j - 1], maxsum[i + (1 << (j - 1))][j - 1]);
				minsum[i][j] = min(minsum[i][j - 1], minsum[i + (1 << (j - 1))][j - 1]);
			}
}

int main()
{
	int num, query;
	int src, des;
	scanf("%d %d", &num, &query);
		for(int i = 1; i <= num; ++i) //输入信息处理
		{
			scanf("%d", &maxsum[i][0]);
			minsum[i][0] = maxsum[i][0];
		}
		RMQ(num);
		while(query--) //O(1)查询
		{
			scanf("%d %d", &src, &des);
			int k = (int)(log(des - src + 1.0) / log(2.0));
			int maxres = max(maxsum[src][k], maxsum[des - (1 << k) + 1][k]);
			int minres = min(minsum[src][k], minsum[des - (1 << k) + 1][k]);
			printf("%d\n", maxres - minres);
		}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值