HDU-1026-优先级队列




Ignatius and the Princess I
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17527    Accepted Submission(s): 5615
Special Judge

Problem Description
The Princess has been abducted by the BEelzebub feng5166, our hero Ignatius has to rescue our pretty Princess. Now he gets into feng5166's castle. The castle is a large labyrinth. To make the problem simply, we assume the labyrinth is a N*M two-dimensional array which left-top corner is (0,0) and right-bottom corner is (N-1,M-1). Ignatius enters at (0,0), and the door to feng5166's room is at (N-1,M-1), that is our target. There are some monsters in the castle, if Ignatius meet them, he has to kill them. Here is some rules:

1.Ignatius can only move in four directions(up, down, left, right), one step per second. A step is defined as follow: if current position is (x,y), after a step, Ignatius can only stand on (x-1,y), (x+1,y), (x,y-1) or (x,y+1).
2.The array is marked with some characters and numbers. We define them like this:
. : The place where Ignatius can walk on.
X : The place is a trap, Ignatius should not walk on it.
n : Here is a monster with n HP(1<=n<=9), if Ignatius walk on it, it takes him n seconds to kill the monster.

Your task is to give out the path which costs minimum seconds for Ignatius to reach target position. You may assume that the start position and the target position will never be a trap, and there will never be a monster at the start position.


Input
The input contains several test cases. Each test case starts with a line contains two numbers N and M(2<=N<=100,2<=M<=100) which indicate the size of the labyrinth. Then a N*M two-dimensional array follows, which describe the whole labyrinth. The input is terminated by the end of file. More details in the Sample Input.


Output
For each test case, you should output "God please help our poor hero." if Ignatius can't reach the target position, or you should output "It takes n seconds to reach the target position, let me show you the way."(n is the minimum seconds), and tell our hero the whole path. Output a line contains "FINISH" after each test case. If there are more than one path, any one is OK in this problem. More details in the Sample Output.


Sample Input
5 6
.XX.1.
..X.2.
2...X.
...XX.
XXXXX.
5 6
.XX.1.
..X.2.
2...X.
...XX.
XXXXX1
5 6
.XX...
..XX1.
2...X.
...XX.
XXXXX.


Sample Output
It takes 13 seconds to reach the target position, let me show you the way.
1s:(0,0)->(1,0)
2s:(1,0)->(1,1)
3s:(1,1)->(2,1)
4s:(2,1)->(2,2)
5s:(2,2)->(2,3)
6s:(2,3)->(1,3)
7s:(1,3)->(1,4)
8s:FIGHT AT (1,4)
9s:FIGHT AT (1,4)
10s:(1,4)->(1,5)
11s:(1,5)->(2,5)
12s:(2,5)->(3,5)
13s:(3,5)->(4,5)
FINISH
It takes 14 seconds to reach the target position, let me show you the way.
1s:(0,0)->(1,0)
2s:(1,0)->(1,1)
3s:(1,1)->(2,1)
4s:(2,1)->(2,2)
5s:(2,2)->(2,3)
6s:(2,3)->(1,3)
7s:(1,3)->(1,4)
8s:FIGHT AT (1,4)
9s:FIGHT AT (1,4)
10s:(1,4)->(1,5)
11s:(1,5)->(2,5)
12s:(2,5)->(3,5)
13s:(3,5)->(4,5)
14s:FIGHT AT (4,5)
FINISH
God please help our poor hero.
FINISH

#include<iostream>
#include<string.h>
#include<queue>
using namespace std;
char Map[1000][1000];
bool vis[1000][1000];
const int dir[][2]={{1,0},{0,1},{-1,0},{0,-1}};
int N,M;
struct node
{
    int x,y;
    int time;
  friend bool operator<(node a,node b) 
  {
      return a.time>b.time;
  } 
int Step[1000][2];//走法的记录  
};
void BFS()
{
memset(vis,0,sizeof(vis));
node p,q;

priority_queue <node>s;
p.time=p.y=p.x=0;
p.Step[0][1]=p.Step[0][0]=0;
vis[0][0]=true;
s.push(p);
while(!s.empty())
{
p=s.top();
if(p.x==N-1&&p.y==M-1)//到了终点
{
int x=0,y=0;
printf("It takes %d seconds to reach the target position, let me show you the way.\n",p.time);
for(int i=0;i<p.time;i++)
{
  if(x==p.Step[i+1][0]&&y==p.Step[i+1][1])
  {
  printf("%ds:FIGHT AT (%d,%d)\n",i+1,x=p.Step[i+1][0],y=p.Step[i][1]);
  continue;
  }
  printf("%ds:(%d,%d)->(%d,%d)\n",i+1,p.Step[i][0],p.Step[i][1],x=p.Step[i+1][0],y=p.Step[i+1][1]);
}
printf("FINISH\n");
return ;
}
s.pop();
for(int i=0;i<4;i++)
{
  q=p;
  q.x=p.x+dir[i][0];
  q.y=p.y+dir[i][1];
  if(q.x>=0&&q.y>=0&&q.y<M&&p.x<N&&!vis[q.x][q.y]&&Map[q.x][q.y]!='X')
  {

      if(Map[q.x][q.y]=='.')
      {
         q.time++;
          int num=q.time;
          q.Step[num][0]=q.x;
          q.Step[num][1]=q.y;
          vis[q.x][q.y]=true;
          s.push(q);
      }
      if(Map[q.x][q.y]>='1'&&Map[q.x][q.y]<='9') 
      {
      q.time++;
      int num=q.time;
      int j=Map[q.x][q.y]-'0'+1;
       while(j--)
       {
       q.Step[q.time][0]=q.x;
       q.Step[q.time][1]=q.y;
       vis[q.x][q.y]=true;
       q.time++;
       }
       q.time--;
      s.push(q);
      }
  }    
}        
}
  printf("God please help our poor hero.\nFINISH\n");//如果没走到终点要对应输出语句。&nbsp;  
}
int main()
{
   int i;
    while(~scanf("%d%d",&N,&M))
    {
    for(i=0;i<N;i++)
       scanf("%s",Map[i]);
    BFS();
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
校园失物招领系统管理系统按照操作主体分为管理员和用户。管理员的功能包括字典管理、论坛管理、公告信息管理、失物招领管理、失物认领管理、寻物启示管理、寻物认领管理、用户管理、管理员管理。用户的功能等。该系统采用了Mysql数据库,Java语言,Spring Boot框架等技术进行编程实现。 校园失物招领系统管理系统可以提高校园失物招领系统信息管理问题的解决效率,优化校园失物招领系统信息处理流程,保证校园失物招领系统信息数据的安全,它是一个非常可靠,非常安全的应用程序。 ,管理员权限操作的功能包括管理公告,管理校园失物招领系统信息,包括失物招领管理,培训管理,寻物启事管理,薪资管理等,可以管理公告。 失物招领管理界面,管理员在失物招领管理界面中可以对界面中显示,可以对失物招领信息的失物招领状态进行查看,可以添加新的失物招领信息等。寻物启事管理界面,管理员在寻物启事管理界面中查看寻物启事种类信息,寻物启事描述信息,新增寻物启事信息等。公告管理界面,管理员在公告管理界面中新增公告,可以删除公告。公告类型管理界面,管理员在公告类型管理界面查看公告的工作状态,可以对公告的数据进行导出,可以添加新公告的信息,可以编辑公告信息,删除公告信息。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值