Phone List

 Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:

  • Emergency 911
  • Alice 97 625 999
  • Bob 91 12 54 26

  In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.

Input

The first line of input gives a single integer, 1<=t<=40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1<=n<=10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output

For each test case, output “YES” if the list is consistent, or “NO” otherwise.

Sample Input


2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

  Sample Output

题意:

给定n个只含数字的字符串,判断是否存在 其中一个字符串是否是另一个字符串的前缀 存在输出"NO" 不存在输出"YES"
一开始超时,后来看了题解发现可以之比较相邻的即可,但前提是要排序,因为只要按从小到大排序后,相邻的两个才可能是互为前缀的,比如
911,91125426,97625999,它排序后911和91125426肯定是相邻的,因为是先按每字符大小排序,在大小相等时,才按长度排序的,就算91125426的长度比97625999的要长,也还是排在它前面
 f[i+1].find(f[i],0) 找到了 就返回 第一个字符的索引

NO
YES
#include<cstdio>
#include<iostream>
#include<cstring>
#include<string>
#include<algorithm>
using namespace std;
string f[10001];
int main()
{
    int k,n;
    scanf("%d",&k);
    while(k--)
    {
        int ok=0;
        scanf("%d",&n);
        for(int i=0; i<n; i++)
            cin>>f[i];
        sort(f,f+n);
        for(int i=0; i<n-1; i++)
        {
            if(f[i+1].find(f[i],0)==0)
            {
                ok=1;
                break;
            }
        }
        if(ok)
            printf("NO\n");
        else
            printf("YES\n");

    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值