CSU---D: Simple Line Editor

      Time Limit: 1 Sec       Memory Limit: 128 Mb       Submitted: 64       Solved: 25    

Description

Early computer used line editor, which allowed text to be created and changed only within one line at a time. However, in line editor programs, typing, editing, and document display do not occur simultaneously (unlike the modern text editor like Microsoft Word). Typically, typing does not enter text directly into the document. Instead, users modify the document text by entering simple commands on a text-only terminal. 

Here is an example of a simple line editor which can only process English. In addition, it has two commands. ‘@’ and ‘#’. ‘#’ means to cancel the previous letter, and ‘@’ is a command which invalidates all the letters typed before. That is to say, if you want type “aa”, but have mistakenly entered “ab”, then you should enter ‘#a’ or ‘@aa’ to correct it. Note that if there is no letter in the current document, ‘@’ or ‘#’ command will do nothing.

Input

The first line contains an integer T, which is the number of test cases. Each test case is a typing sequence of a line editor, which contains only lower case letters, ‘@’ and ‘#’.

there are no more than 1000 letters for each test case.

Output

For each test case, print one line which represents the final document of the user. There would be no empty line in the test data.

Sample Input2

2
ab#a
ab@aa

Sample Output

aa
aa

题意:有两种字符#和@,#表示删除前一个字符,@表示删除前面所有的字符
给出n个字符串,输出处理后的字符串

赋值的时候y没有在for循环里赋值,结果错了好几次

#include<cstdio>
#include<cstring>
#include<queue>
#include<string>
#include<algorithm>
#include<iostream>
using namespace std;
int main()
{
    int y,n;
    string str;
    scanf("%d",&n);
    for(int i=0; i<n; i++)
    {
        cin>>str;
        y=-1;
        for(int j=str.length()-1; j>=0; j--)//找到@字符的位置
        {
            if(str[j]=='@')
            {
                y=j;
                break;
            }
        }
        str.erase(0,y+1);//删除@前面所有字符
        //cout<<str<<endl;
        for(int j=1; j<str.length(); j++)
        {
            if(str[j]=='#')//是#就删除 它 和 它前面字符(两个都要删除)
            {
                str.erase(j-1,2);
                j=j-2;//删除之后字符串长度会改变,记得减去2
                if(j<0)//如果变成了负数,从0开始即可,不然会指向空地址,报错
                    j=0;
            }
            //cout<<j<<" "<<str.length()<<endl;
        }
        while(str[0]=='#')
            str.erase(0,1);
        cout<<str<<endl;
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值