打印队列

The only printer in the computer science students’union is experiencing an extremely heavy workload.Sometimes there are a hundred jobs in the printerqueue and you may have to wait for hours to get asingle page of output.Because some jobs are more important than others,the Hacker General has invented and implemented asimple priority system for the print job queue. Now,each job is assigned a priority between 1 and 9 (with 9being the highest priority, and 1 being the lowest), andthe printer operates as follows.• The first job J in queue is taken from the queue.• If there is some job in the queue with a higher priority than job J, then move J to the end of thequeue without printing it.• Otherwise, print job J (and do not put it back in the queue).In this way, all those important muffin recipes that the Hacker General is printing get printed veryquickly. Of course, those annoying term papers that others are printing may have to wait for quitesome time to get printed, but that’s life.Your problem with the new policy is that it has become quite tricky to determine when your printjob will actually be completed. You decide to write a program to figure this out. The program willbe given the current queue (as a list of priorities) as well as the position of your job in the queue, andmust then calculate how long it will take until your job is printed, assuming that no additional jobswill be added to the queue. To simplify matters, we assume that printing a job always takes exactlyone minute, and that adding and removing jobs from the queue is instantaneous.InputOne line with a positive integer: the number of test cases (at most 100). Then for each test case:• One line with two integers n and m, where n is the number of jobs in the queue (1 ≤ n ≤ 100)and m is the position of your job (0 ≤ m ≤ n − 1). The first position in the queue is number 0,the second is number 1, and so on.• One line with n integers in the range 1 to 9, giving the priorities of the jobs in the queue. Thefirst integer gives the priority of the first job, the second integer the priority of the second job,and so on.OutputFor each test case, print one line with a single integer; the number of minutes until your job is completelyprinted, assuming that no additional print jobs will arrive.

Sample Input

3

1 0

5

4 2

1 2 3 4

6 0

1 1 9 1 1 1

Sample Output

1

2

5

题目的大意是要打印一堆job,每个job有其对应的优先级,当排在最前面的job的优先级不是最高的时候,不打印,把job移动到最后;排在最前面的是最高优先级的时候,打印。多个测试用例,每个用例输入包含n m,代表job个数,和你要打印的job在原始队列中的位置,接下来是一串数字,代表对应位置的job的优先级。你需要figure out指导你的job打印完成一共花了多长时间。每一次打印花费1时间,移动不耗时。

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
using namespace std;
struct A{
    int num,pos;
} f[101],g;
int main()
{
    int t,n,m,a[101];
    scanf("%d",&t);
    queue<A>Q;
    while(t--)
    {
        while(!Q.empty())//这里必须清除不然一直会TLE
            Q.pop();
        scanf("%d %d",&n,&m);
        for(int i=0; i<n; i++)
        {
            scanf("%d",&a[i]);
            f[i].num=a[i];
            f[i].pos=i;
            Q.push(f[i]);
        }
        sort(a,a+n);
        n--;
        int ans=0;
        while(1&&!Q.empty())
        {
            g=Q.front();
            Q.pop();
            if(g.num==a[n]&&g.pos==m)
            {
                ans++;
                break;
            }
            else if(g.num==a[n]&&g.pos!=m)
            {
                n--;
                ans++;
            }
            else
                Q.push(g);
        }
        printf("%d\n",ans);
    }
    return 0;
}



  • 0
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值